Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have the ssh client on my Mac set up to connect using a certificate to a remote linux server.

I'm trying to get my browser to surf through the remote server using a local ssh socks proxy.

The command I issue is the simple:

ssh -D 9999 me@myremoteserver.com

When I change my Firefox proxy settings to localhost on port 9999 (for all protocols), pages load completely blank with no error message or hint what is going wrong.

However, if I change the system's proxy settings (through system preferences->network->advanced->proxies) to SOCKS 5 with localhost and port 9999, Safari can surf perfectly via the remote server.

Any ideas what's the problem and how I can get Firefox to work properly in this setup?

share|improve this question
add comment

2 Answers

It's only a SOCKS proxy, not HTTP/SSL/FTP/Gopher as well. Try telling Firefox about the proxy only in the SOCKS setting.

share|improve this answer
add comment
up vote 1 down vote accepted

Nerdling is right, you are probably using the same settings for all protocols.

Try unchecking the box, enter localhost/9999 for the SOCKS host, and either leave the HTTP proxy host empty or set the port number for it to 0.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.