Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Ubntu 9.04, and had adobe flash and air running fine (which meant I had my beloved tweetdeck). Then I ran the system janitor, and tweetdeck went away. Since then, I've been unable to get flash running again. It looks like I've installed it correctly, the test page at adobe shows flash running, but whenever I try to play flash content it tells me I'm missing a plugin (but won't let me install it). Any thoughts? I've already run system updates and the like.

share|improve this question
    
The title is misleading. Someone might want to edit it. –  James McMahon Aug 5 '09 at 19:18

2 Answers 2

Have you tried first uninstalling and then reinstalling?

Try this:

Take a look in /usr/lib/firefox/plugins and see what's there. There may be a sym link to Flash 7 (especially if you upgraded a distro that already had it installed). Remove that sym link (or .so file), and all should be well. You can then install the latest version, and it should be the only one recognized.

share|improve this answer

Have you ensured ubuntu-restricted-extras is installed? This should properly install flash across the system (including the Firefox plugin).

sudo apt-get install ubuntu-restricted-extras
share|improve this answer
    
Doesn't seem to work. It was already current. –  RabbiDavid Aug 5 '09 at 18:00
    
Try with the --reinstall flag? –  jtb Aug 5 '09 at 21:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.