Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've looked at (and read) all of the similar questions and none of them get exactly to the issue I'm having at home. I have an 802.11g access point (two, actually, with different SSIDs and on different channels). One is an Airlink AR525W. The other is a Linksys WRT54G v.2.

The issue is that at random times, my laptop will lose its wireless connection. This occurs regardless of which access point I'm connected to. When I lose the connection, the affected AP no longer appears in the list of available APs. Also, it doesn't have anything to do with walls or distance. It can happen within 30' and when my laptop is literally within line-of-sight. When it loses the signal, it can take from 10 to 30 minutes to reconnect and it always will without intervention.

I've done all the “standard” things to troubleshoot the problem and it has improved. For example, I surveyed other access points in my vicinity and have selected a different channel for each of my APs that no one else nearby is using. Both APs are configured WPA2/AES. I'm down to wondering [Note: This is not a shopping question. I'm not buying a new AP] if the fact that I didn't drop two bills on my APs and instead opted for more modest solutions has anything to do with it? I've oft wondered why anyone would go for the high-end AP when they didn't have to. Also, I am aware of DD-WRT and have chosen not to go there because only one of my APs is supported.

Oh, and one final thing. It an HP x64 laptop running Windows 7 Ultimate. The wireless interface is an Atheros AR9285 802.11b/g/n WiFi Adapter. All the latest drivers and service packs have been applied. It did the same thing with my old laptop (a Lenovo) so I don't the problem is in the laptop.

It's really annoying when this happens and suggestions of things I haven't thought of or may have overlooked (No, really. As unlikely as it is, I admit that I may have overlooked something :-)) are appreciated.

share|improve this question
    
Do you have any other Wi-Fi client devices? Do they lose the signal at the same time? When one AP stops showing up, does the other one still show up? Can you connect to the other one right away? Are either of your APs near a cordless phone base station, baby monitor, wireless webcam, room-to-room A/V sender, Wiimote, or other 2.4GHz device? – Spiff Sep 8 '10 at 4:42
    
No other WiFi devices in the place. Yes, when the one AP "vanishes," the other is still visible. Yes, I can connect to the other AP immediately when I notice the problem. Of course, if I had something going at the time (like, say, a download), it's toast. I do have an 8-year-old cordless phone in the house. No wireless webcams, baby monitors (my babies were babies over 20 years ago and all have babies of their own), or other devices. – BillP3rd Sep 8 '10 at 6:50
up vote 1 down vote accepted

This is almost certainly 2.4Ghz interference. Take for example this graph:

enter image description here

It looks like CH1 is ok, one distant AP that should cause a complete breakdown. The problem is its misleading as it only shows .11X networks. It doesnt show bluetooth networks, wireless keyboards, baby monitors, microwave ovens, TV Signal senders etc etc. CH1-3 might be the worst part of the spectrum but the graph shows the opposite.

In most non-rural areas now the number of devices using 2.4Ghz has become great that its trending towards being unusuable. Apartment blocks already have huge issues where there are just too many TX points (I can pick up 25+ from my apartment). The solution is to buy 5Ghz capable equipment for your 5Ghz capable clients. For older clients a better AP with large antennas may mitigate the noise enough to work ok.

share|improve this answer
    
Treu. Appartment blocks used to be a big issue with the limited number of channels. But it seels that these days most people are already on the 5GHz band so this problem is slowly going away. Moving to 5GHz yourself is still a good idea though. – Hennes Feb 5 at 11:09
    
@Linef4ult, you explanation is the most reasonable and fits best with the facts (as they were/are). I no longer live there but my setup is identical in my new home - same APs, channels, laptop, etc. - and the problem no longer exists. Seems pretty clear that there was some 2.4 GHz interference being caused by something else. Thanks for coming back to this after all this time. – BillP3rd Feb 5 at 15:28
    
@BillP3rd Didnt realize how old it was, the community bot will bump unanswered questions up sometimes to try and increase answer rates. – Linef4ult Feb 5 at 18:22

There are a couple of things it could be.

1) Interference. Do you have a microwave oven going off nearby, or a cordless phone (many of these can interfere).

You might like to try moving the equipment somewhere else to help pintpoint this. Even a neighbor's equipment (cordless phone etc) could do it.

Suggest you turn off your 8 year old cordless phone for a while and see what happens.

2) A hardware or driver problem with your wireless card. Make sure you're using the latest card drivers.

share|improve this answer

Can you get some other WiFi station to do a scan when this happens? If the AP actually disappears from the air (stops sending beacons) it must be seriously broken. If not (and I would suspect not), are you sure that this is not a DHCP problem? I don't suppose that they are connected to the same wired net and both have a active DHCP server? Do you still get the problem if you assign a static IP to the interface on the laptop?

If you are actually disassociated from the AP (as opposed to the OS disassociating because it decided it didn't like the connection) I would suspect a key exchange/timeout problem but my money is on DHCP.

share|improve this answer
    
None of the APs do DHCP. I have an actual server that I've delegated that task to. – BillP3rd Sep 8 '10 at 14:48
    
So can you verify that the AP actually goes of the air when this happens? Can you associate to the same AP with some other device immediately after this happens? – Per Knytt Sep 9 '10 at 7:10

It happens only on an up-to-date laptop regardless of the AP you are connected to...

I see three possibilities:

  1. The network card disconnects because it's trying to be energy efficient in the wrong way.

  2. Something went wrong installing the card, try removing it from the device manager. (And its drivers) And then install the latest version and hope for it to be fixed... Or you'll need to try a reinstall.

  3. Some kind of odd hardware defect, let's hope not!

share|improve this answer
    
I'm now using x64 Win 7 but had the exact same problem with an x86 XP laptop so I'd doubt it's a problem with the client. That's why I've speculated about the "quality" of my APs. – BillP3rd Sep 8 '10 at 14:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.