Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.
  • Windows Server 2008 with a folder ready to accept a copied file.
  • Vista SP1 or SP2 machine with a 1GB .iso and an .mp3 file stored locally.
  • Gigabit network (not sure if this matters but it amplifies the problem).

In general transferring files kicks butt. Copying the .iso from client to the server runs at Gigabit speeds and takes about 10 seconds. Nice.

enter image description here

If I open Windows Media Player (or any other media player) and play the local .mp3 file (or any other supported media file), and then copy the .iso to the server, speeds slow considerably. The file now takes 70 seconds.

enter image description here

Worse, in some cases this will completely take down the network connection of the client PC and can't be re-initiated via ipconfig or Vista's own Diagnose and Repair. Even Worse, when using Winamp to play the .mp3 the computer will completely blue screen and reboot. Turning off receive window auto-tuning fixes the disconnect and blue screen problems, which is great, but I'd still like to be able to reduce the bandwidth set aside for playing media files.

share|improve this question
    
Vista question involving multimedia, so moving to Super User. pw is ewok.adventure –  Jeff Atwood Aug 5 '09 at 18:08
add comment

migrated from serverfault.com Aug 5 '09 at 18:08

This question came from our site for professional system and network administrators.

3 Answers

up vote 10 down vote accepted

The slow down is likely caused by the multi media class scheduler. Brute force is to disable the service. Mark Russinovich's has a blog entry with info on how to tell if it's the multi media class scheduler by watching the number of ndis packets per second get throttled. Some sites say to increase the tcp window size so you get more data per packet.

This is about vista, but seems to give the registry entry to tweak for the throttling.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\
CurrentVersion\Multimedia\SystemProfile\NetworkThrottlingIndex

A value of 0xFFFFFFFF will disable the throttling, otherwise it's the # of packets per millisecond. Restart is required. Microsoft has a support article KB 948066 that describes the key.

share|improve this answer
    
Tony. Thanks for the great answer! The KB article you linked to, support.microsoft.com/kb/948066, states the max one can change the NetworkThrottlingIndex to is 70 (decimal) which is 00000046 (Hexadecimal). After setting it to the max I turned back on receive window auto-tuning and everything is working perfectly. No dropped connections or blue screens. File copies are slightly throttled down to an acceptable 85MB/s. –  GollyJer Aug 5 '09 at 17:45
    
If Tony's answer worked; you should mark his answer as accepted :) –  EvilChookie Aug 5 '09 at 18:44
    
I had marked as accepted on serverfault.com. Not sure why that didn't come over when it was moved here. –  GollyJer Aug 5 '09 at 19:24
    
Fixed the text to say packets per millisecond instead of packets/second –  Tony Lee Aug 7 '09 at 0:56
add comment

Either what Bcshort said or the first thing I thought of was hard drive I/O.

If you have multiple hard drives - or even a usb stick, try putting the mp3 on there, playing it and the copying the iso.

If speed does not improve, it is most likely what Bcshort said and to do with network card offloading to the CPU, however if it does3 improve, in my oppinion it is something to do with your hard drive not being able to keep up.

I can not speak for local, but I know that from streaming a mp3 from my nas that the whole song (despite being ~4MB) is not loaded in to memory but is streamed live, if I disconnect my network cable, I get about 3 seconds of audio before it drops. This basically means that there are a lot of reads going on at the same time.

To extend my theory - If I have two machines with a GB network and want to transfer 2 large files of the same size, it could easily say 10 minutes for one file. If I highlight both and transfer to the same folder it would say 20 minutes... however if I start a copy for the first one and then copy the second one in a separate process, both of them may go to around 30ish (sometimes more) minutes.

share|improve this answer
add comment

Without knowing hardware specifics..

Seems to me that the network card hands off a fair amount of processing to the CPU - so when the CPU gets busy, the network card has less of a share to the CPU and is therefore being slowed by a processing constraint.

Also be aware windows 2008 and large packets have weird effects on some network hardware.We've found HP NC373 chipsets do not have processing grunt for Checksum & Large send offloading causing dropped packets, so have had to disable that feature.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.