Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Office 2010 (64-bit) installed along with Windows Mobile Device Centre (64-bit) on Windows 7 Pro (64-bit). Outlook is set as the default mail client.

But for some reason, Windows Mobile Device Centre reports the following error:

"Either there is no default mail client or the current mail client cannot fulfill the messaging request. Please run Microsoft Outlook and set it as the default mail client."

Is this a known issue, or is there a fix for the problem.

share|improve this question

5 Answers 5

This article lists three possible fixes, be sure to exit Outlook before each fix!

  1. Go to Start > Control Panel > Programs > Programs and Features, select Microsoft Office 2010 and click the Change button – the Microsoft Office 2010 setup screen will then be visible. Next, click Repair, then click Continue – follow the repair process through to the end and then follow any onscreen instructions.

  2. Manually set Outlook 2010 as the default mail client, via Start > Type "Default Programs" and follow the on-screen instructions to set Outlook as the default.

  3. Browse to the following location:

    C:\Program Files\Common Files\System\MSMAPI\1033

    Next, delete MSMAPI32.DLL, when you start Outlook 2010 the file will be recreated by Outlook upon launch, and ask you to set the application as the default.

Good luck, I hope this fixes it for you...

share|improve this answer
    
Tried it but without restarting after the Office repair step. It did not work. I will retry it a bit later, thanks a lot for the response –  Raybiez Sep 8 '10 at 13:05
    
Nope did not work. –  Raybiez Sep 9 '10 at 9:48
    
See my new answer... :-( –  Tom Wijsman Sep 9 '10 at 10:48
up vote 1 down vote accepted

There is currently no fix for this, see links below:

Microsoft Support KB980513

Microsoft Answers Forum Thread

Office Watch - Outlook 2010 64-bit and Windows Mobile, foget it

I have opted to sync with the Exchange server over the Internet for an immediate remedy

share|improve this answer

In addition to other answers in this thread, from No Default Mail Client Error in Office 2010:

If you have completed the steps above and still get an Office 2010 “No Default Mail Client” error, there are a couple of alternatives.

The first is to manually set Outlook 2010 as the default mail client, via Start > Control Panel > Set Program Access and Defaults and follow the on-screen instructions to set Outlook as the default.

Another way of resolving this issue should the registry fix above fails is to manually delete a specific file.

First of all, exit Outlook 2010, before browsing to the following location:

C:\Program Files\Common Files\System\MSMAPI\1033

Next, delete MSMAPI32.DLL, before restarting Outlook 2010 – the file will be recreated by Outlook upon launch, and ask you to set the application as the default.

I would suggest on the second solution to rename the file, rather than delete, just in case.

share|improve this answer

The below answer is what TomWij was trying to say. I have just put it in a step-wise manner.

To configure Outlook as your default email program in Windows Vista and Windows 7:

  • Click Start.
  • Type "default programs" in the Start Search box.
  • Click Default Programs under Programs in the search results.
  • Now click Set your default programs.
  • Highlight Microsoft Office Outlook or Microsoft Outlook on the left.
  • Click Set this program as default.
  • Click OK.

Make Outlook Your Default Email Program in Windows 98, 2000, and XP

  • Start Internet Explorer.
  • Select Tools | Internet Options from the menu.
  • Go to the Programs tab.
  • Make sure Microsoft Office Outlook or Microsoft Outlook is selected under E-mail.
  • Click OK.

If you are bothered about ""no default mail client" error in Office 2010"

To resolve this issue, you must first remove the corrupted Outlook registry key, and then perform a Detect and Repair operation to have Outlook rebuild the key. To do this, follow these steps.Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base: 322756 (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

1. Click Start, and then click Run.

2. In the Open box, type regedit, and then press ENTER.

3. In Registry Editor, locate the following subkey in the registry: HKEY_LOCAL_MACHINE\Software\Clients\Mail\Microsoft Outlook

4. Select the subkey, and then press DELETE.

5. Click Yes.

6. Quit Registry Editor.

7. Start Outlook.

8. On the Help menu, click Detect and Repair.

9. Follow the instructions on the screen to complete the repair.

Resource from

http://support.microsoft.com/kb/813745

share|improve this answer
    
-1 You've just copied my answer. :-( –  Tom Wijsman Sep 8 '10 at 11:10
    
lol I didnt copy yours I copied it from email.about.com/od/outlooktips/qt/…. Remove that downvote –  subanki Sep 8 '10 at 11:16
1  
The downvote is has been automatically locked till your answer is improved... If you want to prevent this from happening you should check other answers before posting. The two code blocks match my second fix, which originates from the exact same article... The MS link matches to the first fix, and it's meant for other versions than 2010... –  Tom Wijsman Sep 8 '10 at 12:13
    
Try now to remove down-vote , and oh yeah I didn't understand what you were trying to say correctly in your answer so I decided to post mine –  subanki Sep 8 '10 at 12:31
    
None of those worked as well –  Raybiez Sep 9 '10 at 9:49

I'm sorry to tell you, but due to 64-bit compatibility issues there is no solution...

You will need to install the 32-bit version of Office 2010 as this MS KB article states:

There are no plans to update WMDC to improve compatibility with Outlook 2010.

...

If you want to sync a Windows Phone with Outlook 2010,
you can use a 32-bit version of Outlook 2010 that uses a standard MSI installation.

share|improve this answer
    
I know, see my own answer posted 30 minutes ago –  Raybiez Sep 9 '10 at 10:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.