Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just want Firefox to open attachments using the default application without a prompt.

I've checked the "Do this automatically from now on" many times yet certain files types like PDF, RAR (which all have default apps on my Windows 7 laptop) always show the "You have chosen to open" dialog box.

How can I get it to simply open the attachment? Also, why is "Do this automatically from now on" checkbox inactive?

I'm using FF4 but this happened to me in FF 3.x as well.

share|improve this question

3 Answers 3

up vote 0 down vote accepted

See the Mozilla wiki entry File types and download actions.

There is a section titled Unable to set an automatic action which discusses the reasoning for the greyed out box, and it's linked to incorrect MIME types being delivered by the server. So it could be a problem from the other end.

You may also wish to view the Related bugs section at the bottom to see if any are relevant in your case.

share|improve this answer
    
I don't think it's a server issue because this problem is occurring across multiple site and different file types. I did the actions in the "Resetting download actions" section and that seems to be working. Haven't tried it a lot but so far so good. Thanks. –  Shane Sep 9 '10 at 13:24
    
Another problem. With PPT and PPTX files, the dialog appears. It has Open With selected and "Microsoft PowerPoint" is the default. "Do this automatically from now on" is checked (it's no greyed out, so I can check/uncheck it). Yet every time I try to open a PPTX/PPT, the same Firefox dialog box appears. I've checked the Options > Applications settings and it's set correctly to use Powerpoint for PPT/PPTX files. So why does this dialog box appear even though the automatic action is set? –  Shane Sep 9 '10 at 13:33
    
@Shane Don't know I'm afraid, but there's numerous bug reports linked at the bottom of the linked wiki entry in my answer - many of which seem to be directly linked to this issue. Unfortunatly, I'd be inclined to say it's a long standing bug with Firefox. –  DMA57361 Sep 9 '10 at 13:44

Try setting it manually

  • Go to Tools > options >
  • Under Applications , try setting the Action for the required applications manually
share|improve this answer
    
I can't. PDF isn't a listed Content Type. Bug in FF4B5? –  Shane Sep 8 '10 at 15:50

This is a frustrating Firefox limitation that usually stems from the website providing an incorrect mime-type or as an attachment. This is sometimes done to force the browser to download the file instead of opening it directly. One workaround is the InlineDisposition extension which changes the response header. This has worked for me. Firefox now obeys the "Do this automatically from now on" checkbox for PDF files and other file types.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.