Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my iPhone (4), I can set up my company e-mail, which allows me to receive and send e-mail and use the calender to manage appointments. The company is using Exchange 2003.

The problem is that this is the only way I can access my e-mail when I'm not at the office. I've tried setting up an account on Outlook 2007, Outlook 2010, Outlook 2011 (Mac) and the OSX Mail app, but it doesn't work. The server cannot be reached, even though I've used the exact same settings as on the iPhone.

The info I use on the iPhone is:

  • Server name of the company mail server (it's the same as for webmail)
  • Use SSL
  • AD Domain of my account
  • My AD account name
  • Password

When I enter this on the iPhone, it works like a charm, but whatever I try on one of my desktops, it doesn't work.

FYI: I can't ask the company IT guys because according to them, it doesn't work from a remote location, not even on the iPhone (but obviously, that works just fine)

share|improve this question
    
Is there by any chance a vpn setup on the iphone? Also, did you manually set up the server info in outlook or did you let it autoconfigure? I think maybe there is a proxy involved that the iphone is setting up automatically. –  JNK Sep 8 '10 at 13:35
    
No, definitely no VPN (it's my own iPhone which hasn't been touched by the company). I've tried everything in Outlook, manual and autoconfigure. –  Philippe Leybaert Sep 8 '10 at 13:57

2 Answers 2

up vote 5 down vote accepted

Mail.app does not use activesync, it uses ews (check in your account settings) ews means exchange web services, this is quite separate from the activesync provider that the iphone uses. I find it confusing that apple can release activesync capabilities on the iphone and not the mail.app on osx (i have 10.6.4).

This has bugged me for ages! At our company i am the only external user who has a mac, so the problem has only appeared since i started. The owa virtual directory and the activesync api has been exposed through the firewall with certificate translation but the /ews hasn't been.

Long story short, i can access exchange from mail.app and entourage when i am in the office and via VPN but not externally.

The way to make mail.app work with ews is to get the network guys to expose the /ews virtual directory to the firewall and use ssl mapping so that the external requests use the external SSL cert.

E.g. Internal config - exchangeServer.local/ews uses the normal certificate or no cert (if possible) External config - exchange.mydomain.com/ews uses TMG or ISA to present the certificate for that address and transports the ssl-encrypted comunication to the exchange server.

Its as much work as getting owa to work, in fact its the same setup, just with a different virtual folder.

share|improve this answer

The iPhone is using ActiveSync, which essentially runs alongside Outlook Web Access. They use HTTPS, since OWA is usually available for remote users you get ActiveSync as a bonus.

Most Exchange installations have an instance of OWA running somewhere.

Outlook will try to communicate with Exchange via MAPI, which is a proprietary protocol and very rarely enabled for remote access.

Outlook can also be configured to use Exchange via HTTP/RPC or "Outlook Anywhere" (in Exchange 2007/2010 parlance). This requires some more configuration of the server. It uses HTTP or HTTPS (like OWA and ActiveSync) but it is not usually enabled.

I don't understand why Mac OS X's Mail app does not work for you, however. Snow Leopard's uses ActiveSync (same technology as iPhone) to communicate with Exchange so it should be working, unless there are ActiveSync policies to only permit ActiveSync with certain devices (e.g. because the company only uses Windows Mobile 5.5 and iOS, only sync with Windows Mobile 5.5 and iOS devices).

share|improve this answer

protected by slhck Mar 12 '13 at 14:57

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.