Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Now I am using the pull-down menus to set :TTarget, :TCTarget, and :TVTarget to pdf.

I also tried setting g:Tex_DefaultTargetFormat='pdf' and g:tex_flavor='pdflatex', but neither worked.

Thanks!

share|improve this question
add comment

2 Answers 2

up vote 4 down vote accepted

Set

let g:Tex_DefaultTargetFormat = 'pdf'
let g:Tex_MultipleCompileFormats='pdf, aux'

in your config file for vim (e.g. ~/.vimrc). That works well for me here, using vim 7.3.3 on Arch Linux.

share|improve this answer
    
That did it. My error was using set instead of let. Thanks! –  Richard Herron Sep 8 '10 at 20:29
add comment

Add the following lines to ~/.vim/ftplugin/tex.vim (create the file if it doesn't already exist).

let g:Tex_DefaultTargetFormat = 'pdf'
let g:Tex_MultipleCompileFormats='pdf, aux'

This is the same as evnu's solution, but without cluttering up your vimrc.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.