Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having this problem with two programs: Visual Studio 2008 and Notepad++.

If I'm making a webpage and I add a debugger statement to the javascript, it opens up a prompt asking me if I want to debug. If I then click "new instance of VS2008", it will try to open it but fail and give me an error message. I think it's failing because I have the "Run as Administrator" checked and it couldn't prompt me when I open it like that. If I open it through windows it works.

In Notepad++ the problem comes from the context menu "Open in Notepad++"

share|improve this question

migrated from serverfault.com Sep 8 '10 at 23:25

This question came from our site for system and network administrators.

    
Disable UAC when debugging. – Moab Sep 9 '10 at 1:09

If you right click the shortcut to VS2008 and Notepad++ go to Properties > Advanced then check the box always run as administrator.

That should work, I had a similar problem with Wireshark

share|improve this answer
    
Scrap that, I mis-read your question!! – heisenberg Sep 7 '10 at 14:54
    
Don't feel too bad. I know the excitement of answering a question based on the title and then going back to delete it after reading the details. Often, the title is not worded correctly to describe the question. – jsejcksn Sep 8 '10 at 23:48

I've never run into a situation with Visual Studio 2008-2010 where it needs to run as administrator for basic local debugging... that is true for web application and javascript debugging as well. It might be something else?

share|improve this answer
1  
Yeah, you're probably right, I shouldn't be trying to run it as administrator. I should be giving the account it's running under access to whatever files I need. – Mike Blandford Sep 7 '10 at 15:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .