Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

the ssh command is work perfect in my cygwin before. but today it is not work. It always show a usgage. but my command is correct.

$ ssh  root@10.0.0.1
usage: ssh [-1246AaCfgKkMNnqsTtVvXxYy] [-b bind_address] [-c cipher_spec]
           [-D [bind_address:]port] [-e escape_char] [-F configfile]
           [-I pkcs11] [-i identity_file]
           [-L [bind_address:]port:host:hostport]
           [-l login_name] [-m mac_spec] [-O ctl_cmd] [-o option] [-p port]
           [-R [bind_address:]port:host:hostport] [-S ctl_path]
           [-W host:port] [-w local_tun[:remote_tun]]
           [user@]hostname [command]

$ ssh  -V
OpenSSH_5.6p1, OpenSSL 0.9.8o 01 Jun 2010

cygwin version is 1.7

Thants

share|improve this question
    
Did you try reinstalling? –  digitxp Sep 9 '10 at 0:10
1  
What has changed in your system between "before" and "today"? –  garyjohn Sep 9 '10 at 1:10
1  
Do you have an alias or function called ssh? Check with the command type ssh. –  Gilles Sep 9 '10 at 7:07
    
@digitxp . yes, i uninstall the openssh and restart windowXP, and then intall openssh. but type ssh root@10.0.0.1, it show me a usage. –  Mingo Sep 9 '10 at 22:45
    
@garyjohn, the change is, I install the screen package. before that, ssh client work fine. and now i already unintall the screen package, ssh still not work. –  Mingo Sep 9 '10 at 22:47
show 2 more comments

2 Answers

I had this problem and was able to resolve it by downgrading my openssh to "OpenSSH_5.5p1, OpenSSL 0.9.8o 01 Jun 2010"

Just open the cygwin setup program and type ssh, then click the version until you see 5.5p1.

share|improve this answer
1  
SWEET CHRIST THANK YOU. That's an hour of my life I'll never get back. –  Gavin Gilmour Oct 19 '10 at 14:02
    
I had a totally different error Pseudo-terminal will not be allocated because stdin is not a terminal, all I had to do was reinstall (not even to a different version) and now it's fine... I don't get it, but okay, ty. –  Stephen Sarcsam Kamenar May 22 at 17:33
add comment

In order to get Cygwin to use ssh you must install it with ssh (networking) included. When you get to the dialog where the options to check stuff to install or not appears, type "network" in the search box and look for ssh. You need to select this option for it to be installed.

You will find many basic features need this to be installed.

share|improve this answer
    
I don't believe that this is correct. The user should only need to select and install the openssh package. The user should then read /usr/share/doc/Cygwin/openssh.README and run /usr/bin/ssh-user-config. –  garyjohn Sep 9 '10 at 1:09
    
I use cygwin routinely and many users in my office do too. If you simply grab the setup.exe and don't do anything, ie, accept defaults, you will not install ssh functionality. You must choose to install it as I described. I have done this numerous times. There may be another way, but when ssh is not available, this ALWAYS works for me on my XP machine. –  nicorellius Sep 9 '10 at 16:15
    
I see. I misunderstood your answer to mean you had to select some option or package called "networking" when you installed ssh. The OP has already installed ssh, as you can see from the command output he posted. –  garyjohn Sep 9 '10 at 19:26
    
I believe the "Networking" is the subsection in the cygwin installer that contains the ssh package... I could be wrong. –  nicorellius Sep 9 '10 at 19:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.