Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Odd error: if I click on an Excel 2007 file to open it from within explorer, it says "There was a problem sending a command to the program". Excel opens - but it doesn't open the file. I have to then manually open the original file using Excel's "File..Open" dialogue.

All of my other Office 2007 apps work fine, including Word, etc.

Any ideas?

share|improve this question
add comment

migrated from serverfault.com Sep 9 '10 at 6:29

This question came from our site for professional system and network administrators.

3 Answers

up vote 0 down vote accepted

Fixed the problem by upgrading to Excel 2010. Initially I tried the 64-bit version, however, when none of my prior plugins loaded, I switched back to the 32-bit version which worked perfectly. Office 2010 is much nicer - it loads way faster.

share|improve this answer
add comment

In Excel's options (Orb -> Excel Options -> Advanced -> General) uncheck Ignore other applications that use Dynamic Data Exchange. (I had this problem with Excel 2003; it didn't give the error message, but instead just opened the program without loading the spreadsheet.)

MS Knowledge Base entry

Another page specifically mentioning this error and solution

share|improve this answer
    
Thanks for the great hints - however, when I tried all of them (including unchecking the DDE option, installing SP2, etc), it didn't seem to fix the problem. –  Contango Aug 4 '10 at 17:18
    
@Gravitas Have you tried running Setup on the Office installation DVD, and picking the "Repair" option? It's never helped for me, but maybe you'll be luckier. :-) –  coneslayer Aug 6 '10 at 12:05
    
Thx, I'll try that. –  Contango Aug 11 '10 at 22:11
add comment

there is a bug in excel that sometimes gets triggered and causes this. It's an advanced setting with DLL in it.

coneslayer's answer is more precise.

share|improve this answer
    
Thanks - I tried coneslayers advice, but it didn't seem to work. Oh well, I can always just upgrade to Office 2010, that'll certainly fix the problem. –  Contango Aug 4 '10 at 17:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.