Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The Problem

For some reason my XP laptop can not see my wireless network but my Vista laptop can see it fine. I should also say that my XP laptop can see all my neighbors' wireless networks just fine.

My Questions

  • How come my XP laptop does not see my wireless connection?
  • Do I have to manually add my wireless network to the list?
  • If so, why? Why can it see all my neighbor's wireless networks but mine?
  • How can I connect my XP to my wireless network?

UPDATE I thought it would be a good idea to post more details about my setup:

Router: Wireless
Basic Settings

  • brand: Techniclan

  • model: WAR-54G

  • band: 2.4 GHz (B+G)

  • mode: AP
  • SSID: Rilos
  • Channel Number: 13

Advanced Settings

  • Authentication type: Auto Select
  • Data Rate: Auto
  • Preamble Type: Long Preamble
  • Broadcast SSID: Enabled
  • IAPP: Enabled
  • 802.11g Protection: Enabled
  • RF Power: 20dBm

Security

  • Encryption: WPA2
  • WPA Authentication Mode: Personal (Pre-Shared Key)
  • WPA2 Cipher Suite: AES

Access Control

  • Wireless Access Control Mode: Disable

Router: WAN Interface

WAN Interface Setup

  • WAN Access Type: DHCP Client
  • Attain DNS Automatically
  • MTU Size: 1492

Router: Management

Operation Mode

Selected Operation Mode

  • Gateway

    In this mode, the device is supposed to connect to internet via ADSL/Cable Modem. The NAT is enabled and PCs in LAN ports share the same IP to ISP through WAN port. The connection type can be setup in WAN page by using PPPOE, DHCP client, PPTP client or static IP.static IP.

Other unselected operation modes are:

  • Bridgeclient, PPTP client or static IP.

    In this mode, all ethernet ports and wireless interface are bridged together and NAT function is disabled. All the WAN related function and firewall are not supported.

  • Wireless ISP

    In this mode, all ethernet ports are bridged together and the wireless client will connect to ISP access point. The NAT is enabled and PCs in ethernet ports share the same IP to ISP through wireless LAN. You must set the wireless to client mode first and connect to the ISP AP in Site-Survey page. The connection type can be setup in WAN page by using PPPOE, DHCP client, PPTP client or static IP.

Manually Added Wireless Network: Rilos
I access this information by going:

Control Panel > Network Connection > double clicking 'Wireless Network Connection' > in the section called 'Related Tasks' (left hand column, 2nd section) click 'Change advanced settings' > Wireless Network Connection Properties with 3 tabs: General, Wireless Networks and Advanced

General tab

  • Connect using: acer IPN2220 Wireless Lan Card
  • This connection uses the following items:
    • Client for Microsoft Networks: Checked
    • Intel Wireless Connection Agent: Unchecked
    • File and Printer Sharing for Microsoft Networks: Checked
    • QoS Packet Scheduler: Checked
    • AEGIS Protocol (IEEE 802.1x) v3.1.0.1: Checked
    • Internet Protocol(TCP/IP): Checked

Also I have:

  • Show icon in notification area when connected: Checked
  • Notify me when this connection has limited or no connectivity: Checked

Wireless Networks tab

The box 'Use Windows to configure my wireless networks' is checked.

In the 'Preferred Networks' section there is one network named Rilos (Automatic) I click it to select it then click 'Properties' and 'Rilos Properties' window pops up.

In the Association tab I have:

  • Network name(SSID): Rilos
    NOTE: The name Rilos in the text field is grayed out. Can't click into it to change it.

In the 'Wireless network key' section I have:

  • Network Authentication: WPA-PSK
  • Data Encryption: AES
  • Network key: I types my router's password/passphrase into it.

In the Authentication tab everything in there is grayed out and inaccessible.

Connection tab

  • 'Connect when this network is in range' selected.

Thanks, Adam

share|improve this question
    
Have you done this www2.cit.cornell.edu/services/helpdesk/win/wireless/… –  subanki Sep 9 '10 at 10:05
    
That's not applicable, @subanki, since he can see OTHER networks... –  JNK Sep 9 '10 at 10:07
    
What kind of router? Is it in a restrictive mode (i.e. N only) that your older machine doesn't support? What is the physical layout like? It's possible you are getting a better signal from your neighbors if the router is far from the laptop. –  JNK Sep 9 '10 at 10:08
    
check whether your Homegroup of your Vista is the same as your Windows workgroup .. @JNK I am not much into networks just trying help as much as I can from my side –  subanki Sep 9 '10 at 10:10
    
That wouldn't keep him from even SEEING the router though... –  JNK Sep 9 '10 at 10:10
show 1 more comment

5 Answers

You say that the laptop is Windows XP, this can be up to/around 10 years old.

My guess would be that the wireless network is being broadcast in a band or mode (a/b/g/n) that the wireless card in your laptop does not understand.

If however it does understand, my best bet and advised solution would be to manually assign/setup the profile and see if it will connect as sometimes this can work.

Go to the list of preferred networks (Network connections, right click wireless, go to the wireless networks tab), and type the details.

share|improve this answer
    
Ok I went to Wireless Network Connection Properties and in the Preferred Networks area I pressed Add. I typed in the Network name, set Network Authentication to WPA-PSK, choose TKIP as Data Encryption, typed my Network Key in two times and pressed ok. Still I get no connection. What else can I do? –  classer Sep 10 '10 at 16:46
    
@Adam Siddhi - if you have made sure all the settings are correct, I am not sure of anything else you can do :( sorry. –  William Hilsum Sep 10 '10 at 17:03
add comment

On which channel is your WIFI? Depending on your location (the driver settings), your two WIFI cards might not be able to use the same channels.

For example: If your accesspoint uses channel 13 (not allowed in the US but in Europe) and your Vista laptop's driver is set to Europe it can connect. If your XP laptop's driver is set to US or similar then it won't even look if there might be a network on channel 13.

Sidenote: If your accesspoint is set to "auto" + "use all channels" this can give you real headache for troubleshooting a sometimes working and sometimes invisible network.

The capabilities of your driver sometimes can be seen/changed in the Windows devicemanager (devmgmt.msc). Sometimes you get different drivers depending on whether you download it form the manufacturer's US-website or the Europe-website. To be safe, set your accesspoint to the lowest common denominator and only use channels 1-11.

List of allowed channels per region:

  • US: 1 - 11
  • EU: 1 - 13
  • Japan: 1 - 14

Source&Details:
http://en.wikipedia.org/wiki/IEEE_802.11#Channels_and_international_compatibility
http://en.wikipedia.org/wiki/List_of_WLAN_channels

share|improve this answer
    
@openfkg interesting. i went into my router's wireless settings and it says that it is on channel 13. how would I check my Acer XP laptop's wireless card driver? –  classer Sep 10 '10 at 19:28
    
Yes this ended up working. I changed the router channel to 11 and followed with the acer's Wireless card channel. Thanks –  classer Sep 13 '10 at 20:20
add comment

Try changing the channel on you AP. Use something like channel 3 or 5. That may help the XP laptop pickup the AP.

share|improve this answer
    
I am in Europe and @openfkg said that I will only be able to broadcast from Channel 13 which my router is set to. I think the problem is in my Wireless Card driver which I am having trouble configuring. –  classer Sep 11 '10 at 12:41
1  
No. @openfkg said that channel 13 is ALLOWED in Europe and NOT ALLOWED in the US. @openfkg did not say that channel 13 is required in Europe. I'm in the US so I'm not familiar with European WiFi rules. But it doesn't make much sense for an AP to offer other channels if you are not allowed to use them. The idea behind multiple WiFi channels is to allow multiple networks to overlap without conflict. –  Mike Chess Sep 11 '10 at 15:47
    
Yes this worked. Thanks :) –  classer Sep 13 '10 at 20:20
    
@Adam: Mike is right and I've updated my answer to make it more clear. –  bytesum Sep 14 '10 at 10:37
add comment

The wireless connection management tools in Windows XP are not great. I've been using Avanquest Connection Manager, free software that takes over the task from Windows. The freeware InSSIDer is also helpful for visualizing and diagnosing wireless networks. There are a few possible explanations for what's going on, as already described by others here, but I recommend starting off by installing those two tools so you can effectively remove the blinders being imposed upon you by Windows.

share|improve this answer
add comment
up vote 0 down vote accepted

I figured it out. Full answer is here at another question I had http://superuser.com/questions/188089/how-can-i-get-my-router-and-inprocomm-ipn2220-wireless-network-card-connected

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.