Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to update my system which is usually a fairly routine thing. However, today, I ran update, it installed everything, and thunderbird segfaulted on launch. Bemused, I downgraded it. It worked, so I let it update again and it now works.

However, yum is now refusing to upgrade firefox. Specifically, here's the yum output:

$ yum update 
Loaded plugins: presto, refresh-packagekit
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package firefox.x86_64 0:3.5.12-1.fc12 set to be updated
---> Package xulrunner.x86_64 0:1.9.1.12-1.fc12 set to be updated
---> Package xulrunner-devel.x86_64 0:1.9.1.12-1.fc12 set to be updated
--> Processing Dependency: pkgconfig(nspr) >= 4.8.6 for package: xulrunner-devel-1.9.1.12-1.fc12.x86_64
--> Finished Dependency Resolution
Error: Package: xulrunner-devel-1.9.1.12-1.fc12.x86_64 (updates)
           Requires: pkgconfig(nspr) >= 4.8.6
           Installed: nspr-devel-4.8.4-2.fc12.x86_64 (@updates)
               pkgconfig(nspr) = 4.8.4
           Available: nspr-devel-4.8.2-1.fc12.i686 (fedora)
               pkgconfig(nspr) = 4.8.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I've tried --skip-broken and rpm -Va --nofiles -nodigest as it suggests, neither worked. I've also tried yum clean all to clear the cache but the error repeats itself.

Any ideas as how how to solve/diagnose the problem?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I think the problem is xulrunner-devel, try:

# rpm -e --nodeps xulrunner-devel
# yum update

Everything will update, but you won't have xulrunner-devel any more, so if you need that package then the best thing is probably to live without the updates until they get the dependencies fixed.

share|improve this answer
    
That worked, thanks. In any case I can try re-installing xulrunner and should it be a problem remove it again. +1. –  user26996 Sep 10 '10 at 18:37

If You need xulrunner-devel, just update enable updates-testing for a session, and update the things:

yum --enablerepo updates-testing update xulrunner

and at least:

yum update

So You don't need to remove packages. /BTW, if you can, don't use rpm, just yum: yum rmeove xulrunner-devel xulrunner-devel-unstable/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.