Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a USB Hard disk that I am using as a secondary drive just for extra storage.

When this is attached and I start my PC the second screen says searching for mass storage dives for about 5 minutes before continuing on.

The same happens when I have a USB pen disk attached upon boot. If I attach the device after the PC has loaded then it is very quick however plugging and unplugging is not ideal.

Is there away to disable this in the BIOS as I cannot instantly see an option.

On boot it informs me I have an American Trends AMIBIOS in the BIOS setup it states the version as v02.58 2006. This is running on a ASUS MV2 Motherboard.

share|improve this question
add comment

6 Answers 6

up vote 7 down vote accepted

Usually this is because the BIOS is searching your whole drive for a boot sector that it can latch onto. You can sometimes upgrade the BIOS to make it a bit faster (usually just makes it give up easier). The other option is to remove the "removable device" from your BIOS boot order, or place it below your normal HDD.

share|improve this answer
add comment

I had the same problem on an HP desktop. Almost 3 minutes to simply arrive at the Windows splash screen, vs 15 seconds without the USB attached. There are no BIOS settings which force the computer to ignore the attached USB drive. But I discovered a simple solution- purchase a USB hub (I bought a Belkin) and plug the drive into the hub, and the hub into the computer. Problem gone!

share|improve this answer
    
Can't verify this answer but I've had the same problem with Windows XP. After switching to OpenBSD I haven't had that problem anymore –  Earlz May 19 '10 at 18:40
    
Interesting will try later –  John May 20 '10 at 12:36
    
Clarification- I have my computer set up so when the computer shuts down, it turns off the outlet strip connected to all the vampire transformers. Apparently when you boot up the machine, the hub is still waking up when the PC is looking for USB devices. If I attach the hub to a non-switched outlet, then the PC "sees" the USB hard drive immediately, and the boot slows to a crawl. Can't believe the HP bios lets this happen. Not a problem with my Sony Vaio computer. Both running Win7. –  user37700 May 20 '10 at 16:43
add comment

It is dependent on the BIOS, when you have another type of media, an additional loading stage will have to do its job, which take time, especially if it is a HDD because it may not speed up when the PC does.

share|improve this answer
add comment

Some BIOS versions allow you to specify removable media as one of the boot devices. If you remove this from the bios boot order, the system should ignore the USB drive while windows loads.

share|improve this answer
1  
Unfortunately this one does not. –  John Aug 5 '09 at 20:29
add comment

Sadly the Toshiba Satellite (A200) is the same.

If there is a USB drive attached then don't bother with a boot, disconnect the drive first.

The only advantage of the hub is that you can disconnect all drives (connected to the hub) at once - hardly satisfactory.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.