Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I’m using the latest Mac OS X (10.6.4).

It’s possible to customize the currency notation in System Preferences › Language & Text › Formats.

System Preferences › Language & Text › Formats

However, it doesn’t seem to be possible to choose where the currency symbol is placed. Where I live, the currency symbol should be before the actual number. Here’s what I see when I click the ‘Customize…’ button for the Numbers section:

http://i.stack.imgur.com/1J9Na.png

Am I missing something here? Is it possible to change this setting at all?

Edit: This might be related, although there doesn’t seem to be a parameter for the currency character position.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Changing Region in the drop down menu at the top of the screen you showed works for me.

When region is set to Belgium (As in yours) the currency symbol appears after the number. When it is set to United Kingdom, it appears before it.

share|improve this answer
    
Thanks! Shame Apple doesn’t allow us to configure this independently of the region — it sucks having to lie about it. –  Mathias Bynens Sep 10 '10 at 13:12
    
Incidentally, at one point Apple did allow it, then the option seems to have disappeared. (See here osx 10.1: support.apple.com/kb/TA20772?viewlocale=en_US). I'll keep poking around and see if I can find anything. –  James Greenhalgh Sep 10 '10 at 13:43

Format > Cell > Number > Custom "R" #,##0.00 This would be for South African Rand "R"

share|improve this answer
    
This works around the problem on a per-document basis, but not system-wide. –  Mathias Bynens Jul 28 at 7:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.