Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my Windows 7 machine, I get internet through a wired LAN. I have a T-Mobile webConnect Jet stick that I use to send SMS and MMS messages (NOT for data). When Windows detects that the modem is connected (when sending a message), my internet connection goes down and Network and Sharing Center reports multiple networks and no internet connection. How can I... make it not do this?

share|improve this question

2 Answers 2

Windows 7 and Vista allow only one Internet connection at a time. This is a "security" measure.

This is probably your problem: The moment your second connection is established, you lose your first one. As far as I know, there is absolutely no way to have two simultaneous Internet connections on Windows 7.

If several network adapters are available, they will be tested by adapter order for Internet connection. The first suitable adapter will be used, although sometimes Windows will prefer the fastest one, such as preferring wired over wifi.

You might be able to change the order of the adapters, if that's the problem, and place the Lan adapter in first position, so perhaps Win7 will agree to always use it for Internet.

See this article : Change Network adapter priority in Vista.

Another way to change an adapter's priority is by changing its metric.
See this article: Using router metric to specify primary gateway.

The idea is in Properties of the network adapter, to double click Internet Protocol (TCP/IP) and press Advanced. Uncheck Automatic Metric and enter a value for Interface metric. The gateway with lowest Metric is the first to be searched (default Gateway). So set the metric of the modem to be much larger, and hopefully Windows will ignore it for Internet access.

share|improve this answer
    
Hmm. Is there anyway to tell it that a modem isn't ever used for internet? Or is that just assumed? –  colithium Sep 10 '10 at 21:42
    
@colithium: I've added more info. –  harrymc Sep 10 '10 at 22:07
    
The order appears correct. Although no modem appears by name, an entry [Remote Access Connections] is present and is at the very bottom. I still see the same behavior. –  colithium Sep 11 '10 at 4:54
    
I have added some more info. –  harrymc Sep 11 '10 at 14:55

If you use the stick for SMS and MMS only, it is most likely a special feature of the stick and not actually using native features.

Try going in to Network connections and manually disable IPv4 on the modem or manually assign it a fictional static address - e.g. something on your current lan range but make sure that the gateway is left blank and it has a higher metric than the other connections.

This should mean you can still connect and do special features, but internet will not work through it.

If however you are actually saying that your network connection is disabled, please give some feedback and I will try to help further.

share|improve this answer
    
I tried disabling IPv4 and 6 but it seems to revert back the next time a message is sent. Basically the stick doesn't have a data plan. But it's not like Windows would magically know that... –  colithium Sep 11 '10 at 21:27
    
Did you try just changing the device metric to a higher number or lower the one for the normal network connection? –  William Hilsum Sep 11 '10 at 21:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.