Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

maybe there is a trivial solution but I have not found it. when I type an intranet url such as http://name/path Firefox replaces it with http://www.name.com/path and reports an error saying that it cannot find this server. how can I stop it from being so "smart"?

share|improve this question

migrated from stackoverflow.com Sep 10 '10 at 16:46

This question came from our site for professional and enthusiast programmers.

    
Did you really actually include the http://? If so, then folks below referring to DNS are probably right. But when not including that http:// then what if you add that yourself? –  Arjan Sep 10 '10 at 17:21

3 Answers 3

  1. Type about:config into the address bar.

  2. Type fixup into the "Filter" box.

  3. Double-click browser.fixup.alternate.enabled to change its value to false.

(I see I also have google.toolbar.linkdoctor.backup.browser.fixup.alternate.enabled which doesn't seem to have any effect on my browser, but maybe you'll need to disable that as well.)

share|improve this answer
    
This was driving me nuts. Thanks for the help! –  NitroxDM Mar 9 '11 at 19:15

Try to ping the server name, so you will be sure that hostname is added in the DNS registry.

This behavior gets done when a hostname it's not available.

share|improve this answer

This is most likely due to the host not being available in your DNS system.

It looks like your example of http://name/path is to a local server name, possibly in your local network.

Perhaps you are missing the local network in your DNS search "suffixes" or from /etc/resolv.conf on unix.

Try using the FQDN (Fully Qualified Domain Name) for the host, if that works, ensure you have the appropriate DNS search suffixes defined in your network configuration.

Hope this helps for you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.