Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have had dual screen for quite a long time - a 17" laptop and 24" Acer monitor (V243HL). Over a week ago it was working perfectly. However I have just got back from a week long holiday to find that my monitor no longer likes running on its own. I mean if I have it connected and I say I want to only display on screen 2 (the monitor). It changes to 640 x 480 MAX resolution. The only thing I can think of is that I just installed Diablo 2, but then I installed it several weeks ago (only to find it wouldnt work) and the monitor has been working perfectly since then up until now. I have checked for updates to the monitor drivers and found nothing. However this may have simply been the Acer eDisplay software which it was checking for updates for - I will do a bit of searching around to see if it was the drivers.

Does anyone have any idea what this could be? I havent installed any other programs, and I have an Acer Aspire 7738G laptop with Windows 7.

Any help would be greatly appreciated.

Regards,

Richard

share|improve this question
4  
+1 for Diablo 2 –  Xiuhtecuhtli Sep 10 '10 at 18:08
    
Did you install latest patch for Diablo 2? It works fine over here. :) –  AndrejaKo Sep 10 '10 at 18:22

3 Answers 3

Try deinstalling your display/graphics card drivers and reinstall them.

share|improve this answer
    
hmm it seems to be ok now. I figured out that when it changed to 640x480, it would keep display one (laptop) selected - so the resolution dropdown was disabled (understandably). I selected display 2 and selected 1920 x 1080 from the list. It works. Its still weird that it is changing the resolution at all. Maybe its just that it hasnt been connected up for a week so its "forgotten" what resolution it should be using.. Thanks for the help anyway. –  ClarkeyBoy Sep 10 '10 at 18:08
    
Must be a Windows 7 thing. Never had this problem with XP or Vista multi-monitor setups, but Windows 7 likes to randomly screw up my screen resolutions and window locations/sizes. –  Brian Knoblauch Sep 10 '10 at 19:24

Windows 7 has a Projector mode it might be enabled
You might have changed your Display mode

[Windows/SUPER Key] + [P] ,click desired mode
share|improve this answer
up vote 0 down vote accepted

Just because none of the other answers were correct - it was simply a mistake I was making - I will answer my own question to help others who may hit the same problem...

Basically all I was doing was selecting extend this display when display 1 was selected. I expected it to switch to display 2 automatically, but it didnt - it stayed as display 1 but, for a reason I still dont know, the monitor (from what I can remember) had a max of 640 by 480. There was, however, no problem at all with the monitor (the "problem" with which was the purpose for which this question was created)... so the original problem is solved.

Also the laptop now displays up to its maximum resolution so there is no problem there anymore either.

Richard

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.