Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having some issues creating a virtual network using hyper-v. Right now I have PC1 as a Domain controller, it's running the domain D1. All I did was setup Active Directory Domain Services and created a domain.

It appears that all worked fine, I can add users, there's a domain the main pc (PC1) is on. The problem comes in when I try to add a virtual machine to the network. PC2 is also running 2K8R2 and when I go to add to the domain it complains about not being able to find the domain.

I figured this has to do with the DNS, so I overrode the DNS on the adapter to point to PC1 and I was able to add it to the domain. However, now the PC doesn't get internet. I'm thinking this is a DHCP issue, but I have no clue how to proceed.

Any suggestions?

share|improve this question
add comment

3 Answers

It sounds like the DNS server which it is now querying does not have access to the internet and therefore can not resolve internet web pages.

Your easiest solution will be to go to the DNS server of the domain controller and make sure forwarding or root servers are setup so that the domain server can query alternate DNS servers.

share|improve this answer
    
The DNS server's internet is fine. Works dandy. –  Dave Sep 10 '10 at 18:51
    
@Dave - ... So, both computers have a physical connection to the internet, but pc1 is resolving DNS queries to D1 and not your ISP, therefore, it cannot resolve internet addresses. You need to go to D1 and enable DNS forwarding in DNS server so it can resolve external addresses, or enable root hints. –  William Hilsum Sep 10 '10 at 19:11
    
One computer is physical, second is virtual. The DNS and AD machine is the physical. The internet works on the physical and the virtual until I join a domain (on the virtual i have to point it to the physical's IP in the network controllers dns setting, is there a way around this?). I'm going to try DNS fowarding. –  Dave Sep 10 '10 at 19:41
1  
@Dave: Every machine in the domain needs to send its DNS queries to the DNS server on your network, and the DNS server needs to forward any unresolved queries (any request not to domain machines) to external DNS servers. The issue has nothing to do with virtualisation at all. –  paradroid Sep 10 '10 at 19:52
    
@dave - as I and Jason404 said, if this is a problem after changing DNS server, it is clear that the DNS server is not forwarding unresolved queries. –  William Hilsum Sep 10 '10 at 21:11
add comment

From How do I setup Hyper-V internet access to my virtual machines

In Virtual Network Manager on the hyper V box, select the physical NIC that you're using in the properties for each VM's network connection. The connection type will need to be set to "External" to allow the VMs access to the network as if they were "physically" plugged in.

At that point you can treat them as directly attached.

Also make sure Allow management operating systems to share this network adapter is ticked if in a single NIC environment.

Another useful source is Accentient - Virtual Networking in Hyper-V.

share|improve this answer
    
This appears to be a DNS issue, which the OP can easily check by trying to reach a website using an IP address rather than a domain address. eg. 209.85.231.104 –  paradroid Sep 10 '10 at 19:31
add comment

You need a DNS server on your network. I usually add the DNS role to the same (VM) server that runs ADDS. You then have to set the DNS server to forward queries not resolved in the local cache to upstream DNS servers on the internet.

share|improve this answer
    
The DNS server is said to be working well. –  harrymc Sep 10 '10 at 19:57
    
@harrymc: He said that DNS is working for internal requests, but the domain members do not have internet access once they are sending DNS requests to the internal DNS server. This is exactly what would happen when the DNS server is not forwarding unresolved requests to an external internet DNS server. –  paradroid Sep 10 '10 at 20:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.