Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem similar to this question, where I have a dialog box (several, actually) that opens on a disconnected monitor. Since the dialog box does not have an entry on the taskbar, I cannot invoke the "move" command. Short of reconnecting the monitor, is there any other way to get the dialog boxes back to my main monitor? I'm using Windows XP, SP2.

share|improve this question

3 Answers 3

up vote 11 down vote accepted
  1. Use Alt-Tab to make the app/dialog active.
  2. Press Alt-Space, followed by the 'm' key (in english OS - *M*ove, different letter in other languages).
  3. Hold the left arrow for a second.
  4. Move your mouse (without pressing any mouse buttons) until you see it.
  5. Press enter when you have it where you want. (Left click works as well.)

If the dialog is modal (like an open file dialog), it should get focus when the main app is selected, even if it doesn't have an entry on the taskbar. The Alt-Space followed by 'm' selects the move option on the window.

share|improve this answer
    
Whoo-hoo! Awesome, except that (for me) for step 5 hitting enter does work, but right-click doesn't. Anyway, solved! Thanks! –  Aerik Sep 10 '10 at 23:05
    
You can press Enter or left click to drop the window. –  Bavi_H Sep 11 '10 at 2:24
    
@Bavi_H: fixed. Thanks! –  yhw42 Sep 11 '10 at 4:42
    
I've also seen this happen many times. I knew the fix already, but it blows me away that such a glaring omission could be ignored between Win XP, Vista, Me, and 7. Why bring a window up on a screen that doesn't exist? Don't Microsoft's programmers actually use windows? Multiple monitors have been supported in Windows for, what, 15 years? </rant> –  localhost Feb 25 at 3:39

It sounds like your computer still thinks the external monitor is attached, because when there is only 1 display, all dialogs should automatically be moved to that display. I would check in your display properties to make sure that your remaining monitor is the only one set up, and that the other one is indeed disconnected.

share|improve this answer
    
I would think it would work that way too; that was the first thing I checked. Thanks though. –  Aerik Sep 10 '10 at 21:29
    
Does the problem persist even after a reboot? –  nhinkle Sep 10 '10 at 22:43

Options include:

  • Move your main monitor to the second port, move them all back, then reattach.
  • You can also disable the second display completely in display properties
    • Right click desktop
    • properties
    • settings
    • Dropdown for display
    • Select second display and uncheck "extend my desktop..."
share|improve this answer
    
Yes, I actually ensured that "extend my desktop" was unchecked already, thanks. –  Aerik Sep 10 '10 at 21:29
    
@Aerik - Sorry! –  JNK Sep 10 '10 at 23:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.