Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows 7 x64 Pro. This problem happens only with removable drives.

Whenever I double click them I get an "Application not found" error, instead of having explorer displaying it's contents. This is because the default action (the one that appears in bold on the drive's context menu) is not what it should be ("open"), but "Install or execute programs on the drive". The solution here is simply to put it back to normal, like with any other folder or fixed drive, and, possibly, remove this entry, wich I cannot figure out how it got there in the first place... I can still "open" the drive by right clicking and selecting "open".

I ran into this kind of problem on Windows XP and it was fairly easy to fix, but I cannot find a solution on Windows 7. Do you guys know how this is done?

Also, note that my system's language is not English, so the messages I posted are translated by me and may not be exactly the ones used in your version.

share|improve this question

3 Answers 3

If you click on the Start Orb then choose Default Programs, you should be able to configure it there.

Go to Change Autoplay Settings and click the default button at the bottom which should reset all the settings.

share|improve this answer
    
I don't see any entries on Default Programs about folders and there's no way to add it. On Autoplay Settings, asking to restore the defaults does the same as my previous attempt, nothing. –  Slpk Sep 12 '10 at 12:43

Click on the Start button and in the start menu search box, type auto and press enter, or if search does not find Autoplay, click on Start \ Control Panel \ Default Programs \ Change Autoplay settings

alt text

Listed are all the possible media and devices along with their default or changed autoplay settings. With each media or device, is a pull down (arrow) that allows you to modify the autoplay action. For example, if you wanted Media Player to start for all Video files, click on the arrow next Video files, select Windows Media Player then click on Save:

alt text

Resource from here

share|improve this answer
    
I changed the value for "software and games" to "open folder to view files...", the rest to "take no action" and restarted. Nothing changed, I still have "install or run program" as the context menu's default. –  Slpk Sep 12 '10 at 12:46

You said this is only happening with removable drives. Do you mean it only happens with some USB sticks? If so, than you may have had a virus on your USB stick. Such viruses create an autorun.inf file to tell Windows that when you double-click the USB stick, it should open an .exe file on that stick that is usually the virus.

I have seen this many times: an antivirus detects and deletes the virus file from the stick, but it only deletes the .exe file. The autorun.inf file remains on the stick and when you double-click it, you get an error because Windows can't find the .exe file. Look for a file called autorun.inf on your USB stick, and if it's there you can delete it. After that, remove the stick and plug it in again and check to see if it works. The autorun.inf file may be hidden, so you may need to enable show hidden files, folders and drives, and also uncheck "hide protected operating system files".

If you delete the autorun.inf file but it gets created again, you may have a virus on your computer that is always re-infecting your USB stick. You should check for that using an updated antivirus.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.