Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a commercial Network Addressable Storage (NAS) that I use as a file storage location with multiple computers and operating systems. I prefer to get to it by its IP address rather than set it up as a custom Windows device... which is possible, but which I do not understand, am not comfortable using, and will not use.

There are several Windows (only) executable files stored there as well, so they don't have to be on every XP computer, and I know all computers will be using the same version.

If I copy one of these executable files into a folder on my C: drive and run it from there (via a double click in windows explorer), it runs just fine. However, if open the NAS folder containing the program in windows explorer and run it with a double click, XP gives me a dialog saying: "Open File - Security Warning. The publisher can not be verified. Are you sure you want to run this software?"

This gets to be annoying. It is apparent that XP has some trust issue with files on the NAS different from files on the C: drive.

Is there any way to prevent XP from presenting me with that dialog?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Go to Internet Options either through Control Panel or Internet Explorer and under the Security tab, you need to add the IP address of the nas in to the Trusted Zones list.

After this, click Custom level... and under Launching applications and unsafe files, change it to Enable.

You can also do this on the Internet Zone, however this is potentially dangerous as it gives pretty much everything those permissions. By doing it to the Trusted sites zone, we are only giving this to the sites you put in the zone.

alt text

Now this should hopefully stop the warning message.

share|improve this answer
    
Thank you for the very clear directions. Unfortunately, it did not seem to solve the problem. I tried listing it (separately) 3 different ways: //10.0.0.60, 10.0.0.60, and 10.0.0.60. (I also tried back slashes, but the interface changes them to forward slashes.) None worked, and some actually added a second dialog asking if I wanted to copy or move files from this zone. –  Mark T Sep 11 '10 at 1:10
    
@Mark T, I am so sorry, I left out half the steps - I have had a long week and I am not sure what happened :S Could of sworn I typed them. –  William Hilsum Sep 11 '10 at 1:26
    
Wow, great! It finally starts programs easily. I would have never found that on my own. Thank you so much! –  Mark T Sep 11 '10 at 12:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.