Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

I have this USB flash drive with a Linux partition that I use inside VirtualBox.

Each time I insert it into the USB port, windows keeps asking if it should format it.

Is there anyway to disable Windows from asking that?

Disabling auto-run has not resolved the problem unfortunately. Windows will still check if the disk contains a partition it knows about, and ask to format if it doesn't know it.

RegEdit ScreenShot

Really nice try though, any other ideas?

share|improve this question

migrated from stackoverflow.com Sep 11 '10 at 3:06

This question came from our site for professional and enthusiast programmers.

marked as duplicate by Mokubai, Tog, Breakthrough, AthomSfere, Shakehar Oct 7 '13 at 19:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

4 Answers

You could try using the registry key provided here to disable Autoplay for removable drives...

But, please note: I haven't tested that regkey and can't vouch for what it does, and disabling Autoplay for all removable drives is a bit of a nuclear option.

Alas, that's all a Google search managed to turn up.

share|improve this answer
add comment

Doesn't work. Next time you plug it in, it asks again for the drive. Why? because my USB drive has two partitions: one appears as a CD partition, in order for the autorun.inf to play and launch the decryption utility that will mount the partition Windows 7 asks to format.

In my case, the USB mounts as E: and then, if you provide the right password, will mount H: as the USB key partition. If I plug the key and suppress H:, then provide the password, the key will recreate that H: partition. Next time you plug it in, H: will be detected by Windows 7, not recognized, and Win7 will ask again to format the partition.

share|improve this answer
add comment

Control Panel..Administrative Tools..Computer Management..Disk Management

Right-click on your drive and choose "Change Drive Letter and Paths", then choose "Remove".

share|improve this answer
add comment

You could try making it recognized after all by installing a file system driver, for example Ext2 Installable File System For Windows, which also works with ext3

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.