Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a way to globally set the default video player in Ubuntu 10.04 (and soon 10.10) to VLC? (unless you really think there is another, higher performance player, in which case do let me know)

share|improve this question
add comment

3 Answers 3

up vote 7 down vote accepted
  • One way is to right click, say on an AVI file, select 'properties' and select the 'Open with' tab. Select VLC or add it and close properties. From then, all AVI files will be opened with VLS.

  • For DVDs you can go to Panel menu > System > Preferences > Removable Drives and Media and go to the 'Multimedia' tab and change it from Totem.

Resource from Here

  • Detailed Answer would be

1 Click the "System" menu at the top of the screen, then click "Preferences" and "Preferred Applications."

2 Click the "Multimedia" tab.

3 Click the drop-down menu and select "Custom."

4 Type "vlc %f" in the "Command" box.

5 Click "Close" to make VLC your default video player.

Resource from here

share|improve this answer
1  
+1 for editing whil I was posting ;-) now I guess it´s the perfect answer. –  Diskilla Sep 11 '10 at 16:50
    
Didn't work in my case. I went with ZS6JCE solution superuser.com/a/359967/68816 –  dnl Oct 20 '12 at 7:06
add comment

Another way is to set VLC-Player as default player for all your video files.

  • Click the "System" menu at the top of the screen, then click "Preferences" and "Preferred Applications."
  • Click the "Multimedia" tab.
  • Click the drop-down menu and select "Custom."
  • Type "vlc %f" in the "Command" box.
  • Click "Close" to make VLC your default video player.

That´s how I did it according to this website. Worked for me ;-) But I guess subanki´s answer is more specific because it sets the player for the file extension.

share|improve this answer
add comment

According to: http://wiki.videolan.org/How_to_make_VLC_the_default_player

You can do the following:

  1. Go to /usr/share/applications/ and find the following two files
    • defaults.list
    • mimeinfo.cache
  2. Change all "totem.desktop" to "vlc.desktop"

I personally copied all the totem.desktop lines to ~/.local/share/applications/mimeapps.list and then search and replaced all to "vlc.desktop".

Please note that the format to copy is:

[MIME Type]=[Name of the Desktop Entry file]
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.