Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I would like to remove the delay that occurs with ssh when logging in from my intranet but retain the delay when logging in from the internet.

Is this possible?

share|improve this question
May I ask why you would ever want a delay, on either end? – John T Sep 11 '10 at 22:04
You would want a delay when accessing from the internet to make brute force attacks very slow. – Pram Sep 12 '10 at 6:28
is this what you loking for – subanki Sep 12 '10 at 7:20
up vote 2 down vote accepted

Problem often occurs when reverse dns lookup enabled by SSDH. Try to use 'UseDNS no' in config.

share|improve this answer
That looks like it did the trick. Thanks – Pram Sep 12 '10 at 11:24
hahahahr, so now intranet AND internet have the same delay? :)) – akira Sep 12 '10 at 11:56

use ssh-keys to authenticate yourself from the intranet machines.

your password-based authentication runs on the client against the keys you are using. once that is done, there will be no delay when authenticating against the server (sshd_config MaxStartups)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .