Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a server that runs a minimal instalation of debian 5.0. The server has only 128mb of ram.

I am trying to install virtualmin but I keep getting the message:

............spinner: fork: Cannot allocate memory

I have read that this is because the system is out of memory. I am wondering if there still is a way to get this installed om my machine.

After the installation is complete I have methods of reducing the amount of memory the application usses.

share|improve this question
    
Your question is missing some important information: the full error messages, how you're installing virtualmin (deb? tgz? from where?), and some information about your server (virtualized, presumably?) –  Gilles Sep 11 '10 at 20:49
    
Ok I will do the instalation again and post a detailed error log. –  Saif Bechan Sep 11 '10 at 21:18

2 Answers 2

up vote 3 down vote accepted

I would recommend setting up a temporary swap file to increase the available memory. You can setup a swap file using the following steps:

  1. Determine the size of the new swap file and multiple by 1024 to determine the block size. For example, the block size of a 64 MB swap file is 65536.

  2. At a shell prompt as root, type the following command with count being equal to the desired block size:

    dd if=/dev/zero of=/swapfile bs=1024 count=65536
    
  3. Setup the swap file with the command:

    mkswap /swapfile
    
  4. To enable the swap file immediately but not automatically at boot time:

    swapon /swapfile
    
share|improve this answer
    
Hi thank you I wanted to know just this! I will try it out right away. Do you have any idea how I can calculate how big the swapfile should be, or is it just a trial/error situation. –  Saif Bechan Sep 11 '10 at 20:47
    
I am trying to enable the swapfile. I am running OpenVZ, are there any special options. When I try to enable the swap i get the error message ´swapon: /swapfile: Operation not permitted´ –  Saif Bechan Sep 11 '10 at 20:54
    
Same problem here. I decided to buy more RAM. –  mcb Jan 7 '12 at 10:14

Try stopping as many services as possible while you install the program.

If you were installing with apt, try installing with dpkg instead (dpkg -i /var/cache/apt/archives/virtualmin*.deb, or dpkg --configure -a if the package has already been unpacked and the configuration stage failed).

It looks like something in the installation script is using more memory than you have. If you post the full output from the installation script, you may get better answers.

Some hosting companies allow you a temporary boost of memory for the initial installation or for X hours a month. If yours does and all else fails, take advantage of this. And if this is an embedded server rather than a virtualized server, create a swap file.

share|improve this answer
    
Hi, I have no option to boost my performance, and I am installing it trough a .sh script. The tutorial I use does not use apt-get. I have done apt-get upgrade before the instalation so everything should be ok. –  Saif Bechan Sep 11 '10 at 20:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.