Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an nVidia 750a motherboard running Windows 7 32-bit - with an onboard gigabit ethernet contoller.

The ethernet contoller seems to have stopped working to some degree --- it wont retrieve an IP address using DHCP or static IP.

ipconfig returns the Windows auto IP address.

I have updated with the latest motherboard drivers - without any difference. I put in a wireless card into my PC and it connecst to my router without any problem and gets an IP address.

I also tried connecting my PC directly to my cable modem and bypassing my router - same problem. I also tried using each of the 4 ports on my router - same problem.

Other devices in my network can connect wirelessly to my router without any problem.

Question is - how do I verify that my motherboard ethernet controller is bad?

share|improve this question
up vote 1 down vote accepted

Personally, I would use a Linux live disk such as Ubuntu, and see if you can connect from that.

If the answer is yes, there is some misconfiguration in your Windows install.

Have you recently installed any security applications?

Apart from that, you said Windows won't retrieve an IP address using static IP.... This is a contradiction and you need to rephrase.

In order to do a quick test, can you try to copy down exactly the IP, Subnet mask, Gateway and dns settings from another machine then disconnect that machine and manually apply them to the desktop and see if you can connect?

If none of these steps help or you need further help, please say.

share|improve this answer
tried your test which didnt help resolve the problem, although this is the best answer. thanks. – Adam Sep 15 '10 at 1:10

Have you tried using a different ethernet patch cable?

share|improve this answer
not yet - just did and that fixed the problem. Wow. props to u sir. – Adam Sep 15 '10 at 1:10

If your computer and router are configured for DHCP, try these commands to get a new IP address:

ipconfig /release *Con*  
ipconfig /renew

If that doesn't help, try repairing the network connection: right-click it in the Network Connections list and select Diagnose. If that doesn't help, try this: in the Device Manager, find the network adapter, right-click it and select Uninstall. Restart your computer. Windows should re-detect and configure the network adapter.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.