Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I ran apt-get upgrade on a Ubuntu 8.04 32-bit server. It upgraded lots of packages but failed here:

Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.24-16-server
update-initramfs: lilo run failed for /boot/initrd.img-2.6.24-16-server:

Warning: LBA32 addressing assumed
Fatal: raid_setup: stat("/dev/sda")
dpkg: subprocess post-installation script returned error exit status 1
E: Sub-process /usr/bin/dpkg returned an error code (2)

The only hard drive in the system is /dev/hde and apparently update-initramfs is trying to find /dev/sda.

Now I'm afraid that the system won't boot the next time I start it. Any idea how to solve the problem? Please let me know if you need any additional info.

share|improve this question

2 Answers 2

Do you have a backup initrd.img-2.6.24-16-server in /boot? If so, compare the size of the two. Are they different? You could try replacing the new one with the backup and see if it boots then. That worked for me after an update (GUI) on an old Ubuntu desktop (8.04) of mine broke my initrd.img. I might be way off base, but if your system won't boot it could be worth a try.

share|improve this answer
up vote 0 down vote accepted

Apparently the solution was to run apt-get remove lilo.

This way, it doesn't need to upgarde the relevant packages anymore.

Pleane note that Lilo still functions as the boot loader, it just uninstalls the installer/bootstrapper of Lilo.

share|improve this answer
    
Thanks Tom for expanding my answer –  netvope Nov 11 '11 at 21:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.