Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Home router (netgear dg834g) does not respond to requests for MX addresses from the internal network. Is this normal? It DOES respond to other reqeusts.

My previous router - BT Voyager 2091 - worked responded to both MX and non-MX requests.

I know it's unusual, but I run my own mailserver. After the router swap no outgoing email got sent. The email program (VPOP3) reported "427 No response from the DNS server - please check your settings. (failed)".

I ran Wireshark on the network and it was clear that the router did not respond to MX requests, yet it did respond to other DNS requests. Its not a negative response, it seems to completely ignore them.

As a workaround I have configured the VPOP3 program to use the Google public DNS servers that's working fine.

If I buy another router am I likely to find this behaviour again? Or have I just been unlucky?

Extensive Googling has not turned up anyone else with this issue. That may reflect how few home users run their own mailserver. I doubt it affects any other kind of usage.

share|improve this question

migrated from Sep 12 '10 at 15:58

This question came from our site for system and network administrators.

1. What model DG834? Netgear changed the firmware architecture completely between v4 and v5. 2. Read RFC 5625 for hints. – Alnitak Sep 12 '10 at 7:17
Does incoming mail work? Only outgoing mail does not? Can you ping "" and get an ip address from your mail server? – Cypher Sep 16 '10 at 4:58
Incoming mail was fine. The only problem was that VPOP3 got no responses when it asked for MX records. The request went to the router and the router appears to discard the request. – RichardHowells Oct 16 '10 at 19:12

I've studied the behaviour of the DNS proxies inside home routers extensively (including the DG834), and never seen a problem that was query type specific.

I have seen many problems related to the length of a DNS response, and/or unusual response flags.

  1. What rev hardware and firmware is the router?
  2. What's the actual DNS query you're sending?
  3. Is this mail server inside or outside of your network.
share|improve this answer
Not sure of the hardware. It says V1.05.00 for the firmware. – RichardHowells Oct 16 '10 at 21:01
there should be a more detailed model number on the base of the unit – Alnitak Oct 16 '10 at 21:20

If the new NAT router has SPI (Stateful Packet Inspection) and it is enabled, you might try disabling it. A lot of the SPI implementations are around assumptions that seem to counter against hosting server based applications behind/within the SPI-protected network.

share|improve this answer
It appears that this product line does implement Netgear's interpretation of SPI (as each vendor will vary their own interpretations across their product lines and firmware revisions). You might attempt to place the server into the DMZ. That might have a different bearing as to how SPI is applied to that host, if it is a factor (which is common). The other option is, as pointed out by Martijn Heemels, where a different firmware revision may correct the behavior too. – Anonymous Sep 12 '10 at 9:54
@User48838 - Good suggestion. I did try putting the server into the DMZ, preserving the setting that it should to go to the router as its DNS server. It made no difference. – RichardHowells Sep 12 '10 at 15:04

Have you tried both of these?:

  • Configure your server to use your router as the DNS server.
  • Configure your server to use your ISP's DNS server.
share|improve this answer
Those are the settings I have that do not work. They did work on my previous router. – RichardHowells Oct 16 '10 at 19:18

This is quite unusual. I've never seen a home router that treated some DNS record-types differently from others.

I would expect this behaviour to be caused by a bug in the firmware, or perhaps a very obscure setting but I can't guess at a reason. You've already tried to debug with Wireshark so I'll assume you have some knowledge of networking, and have already pinpointed that the issue is actually with your router.

Check with the manufacturer's site for a firmware update.

share|improve this answer

I don't see anything in the product manual that states that the router supports DNS, so I don't know what you are expecting it to do.

I'm assuming your mail traffic runs on standard SMTP port 25? If so, you'll want to set some NAT routes for traffic on that port to/from your mail server, and setup your router to use your ISP's DNS servers. That should accomplish what you are looking for (assuming you want all mail traffic to go through your mail server).

share|improve this answer
I expected this (from the manual). It might not be 'proper' DNS, but it was what I wanted. When DHCP is enabled and no DNS addresses are specified, the router provides its own address as a DNS server to the attached PCs. The router obtains actual DNS addresses from the ISP during connection setup and forwards DNS requests from the LAN. – RichardHowells Sep 14 '10 at 18:51
@RichardHowells: Right, so your router doesn't provide DNS at all, your ISP does. In which case it sounds to me like you just need to setup some routing to handle mail traffic to and from your mail server. DNS plays no part in your mail server being able to forward mail out to the WAN, it simply translates names to ips - which your router does not do. Your ISP's name servers typically do that. If you DID have DNS capability, you wouldn't want to forward to your ISP anyway - would be simpler to refer to the root name servers. – Cypher Sep 16 '10 at 4:52
Sorry but DNS DOES play a part. The mail server program (VPOP3) needs to get an IP address. When sending to it needs the IP address for the mailserver that serves Wireshark shows me VPOP3 sending the query for an MX record and the router seems to silently discard it. That stops VPOP3 from sending the email. – RichardHowells Oct 16 '10 at 19:16
@RichardHowells: you're thinking too narrowly. Of course DNS is needed (and that seems to be the problem), but your router isn't providing it and won't provide it (it can do dynamic dns - see the link to the product manual if you want to play with that). Setup a name server inside your network (your mail server) and point it at global root hints ( Done deal. Almost like what you are doing now, but then you won't be relying on a single name server outside of your control. :) – Cypher Oct 17 '10 at 4:35
up vote 0 down vote accepted

I never discovered why the Netgear router behaved differently to the old one.

I am leaving the mailserver program configured with the Google public DNS server addresses. It's a workaround but I am satisfied with it.

share|improve this answer

I guess your previous DNS server is not working properly, so, it doesn't forward back the request.
Try again Monday to get MX responses from it. If is not working let the owner know about this.
I will try to manually add a public DNS in the router's config (if possible) and test against this one.

share|improve this answer
Thanks but this does not answer the question. My ISP's DNS server is working fine. The old router was fine with it. The new router somehow loses or ignores the request. – RichardHowells Sep 11 '10 at 19:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .