Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I don't really know a good way to describe this problem, so please take a look at the picture. There should be something odd about it. ScreenShot

My problem is that when I install Serbian Latin layout, CJK layouts appear under list of available layouts in the language bar, but not in the Text Services and Input Languages. This is a problem with me because I often use keyboard shortcuts to switch quickly between languages. This way, I need to pres the key combination 4 more times in order to rotate currently selected layout.

Normally when Serbian Latin layout is installed, it doesn't drag CJK layouts together with it. I'm unable to connect start of this behavior to installation of some particular piece of software because I usually don't have Serbian Latin layout installed, since I rarely use it.

When I remove Serbian Latin layout, CJK layouts disappear too.

Is there a way to solve this issue without reinstalling windows?

share|improve this question
    
Is Serbian part of the Eastern Languages pack? if not then you could simply uninstall the eastern languages maybe then they would not react like this. –  rzlines Sep 12 '10 at 21:00
    
@rzlines It shouldn't be. I'll try with uninstalling Eastern Languages pack. –  AndrejaKo Sep 12 '10 at 21:02
    
@rzlines Can you tell me what should I do to uninstall Eastern Languages pack? I checked under Region and Language and I don't have any East Asian language installed. –  AndrejaKo Sep 12 '10 at 21:06
add comment

3 Answers

up vote 2 down vote accepted

I managed to remove the phantom layouts by installing the layout in Text Services and Input Languages and removing it. It remains to be seen if this solution is permanent or not.

EDIT Finally found out what was causing the issue. Office 2010 installed IMEs for CJK languages and they were in startup. After I removed them from startup, eastern layouts finally stopped appearing

share|improve this answer
add comment

Damn didn't look properly at your screenshot sorry you have 7 installed. Can you try Install/Uninstall Languages (you will find this on the languages tab) and check if CJK are available there then you can manually uninstall them. (The Eastern Language pack is an XP thing)

share|improve this answer
    
None of the east Asian languages are on the installed list. –  AndrejaKo Sep 12 '10 at 21:50
    
okay can you check that while you selected the Serbian language these other languages (CJK) or not ticked I've done the same thing on my computer and I its not acting up like the way yours is. Could be that those too have gotten ticked by a freak accident. –  rzlines Sep 12 '10 at 22:06
    
I know that they don't show up on the screenshot but just check it once –  rzlines Sep 12 '10 at 22:08
    
I meant, in Install/Uninstall->Uninstall languages, I only have English (which is the system language) and Serbian Latin (which I need for handwriting recognition). –  AndrejaKo Sep 13 '10 at 0:41
add comment

I did not have those tools in the start-up folder, nor did installation contained IME for CJK languages.

But they were in the 'language proofing tools' (which is a separate setup). And removing them from that install fixed the problem for me: enter image description here

Edit: In the end, I also had to edit the registry as described in This answer

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.