Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having a problem with my Revo 3610 which is connected to my TV via HDMI.

For some reason it will not do the HDMI handshake with the TV, so my TV does not think that there is anything in the HDMIport.

I have tested the TV and it works fine with my laptop and DVD player.

It does work sometimes, but this time it's failed for two days in a row. I've tried rebooting and turning the TV off and on, but nothing helps.

I can trick the TV to listen to the HDMI by connecting with my laptop and then changing the HDMI back to my revo; this results in the image going through nicely but there is a big fat "Check signal cable." message on the screen.

I have also tried changing the resolution in the revo but this does not help either.

Has anyone else had this problem before, and if so how did you fix it?

share|improve this question
up vote 0 down vote accepted

Try forcing the DisplayDevice via /etc/X11/xorg.conf. It may be initializing only the VGA and ignoring the HDMI port. On my Zotac (also Nvidia ION) it looks like this:

Section "Device"
        Identifier "nvidia"
        Driver  "nvidia"
        Option  "NoLogo"              "true"
        Option  "DynamicTwinView"     "false"
        Option  "FlatPanelProperties" "Scaling = Native"
        Option  "ModeValidation"      "NoVesaModes, NoXServerModes, NoVertRefreshCheck, NoHorizSyncCheck"
        Option  "UseDisplayDevice"    "DFP-1"
        Option  "ModeDebug"           "true"
    Option  "HWCursor"            "false"
share|improve this answer
I installed windows 7 and all is fine now ;D – DoomStone Mar 27 '11 at 20:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.