Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to share some files on my computer using IIS within the wwwroot folder. I'm currently getting a 403 error when I enter the URL ipaddress/Folder. Is there any way to get rid of the 403 error and allow my computer to make the files public?

share|improve this question
    
Yes, but to tell you how we need to know what OS (and hence, version of IIS) you're using. – BillP3rd Sep 13 '10 at 6:40
    
I'm on IIS7 and windows vista – cfarm54 Sep 13 '10 at 18:07
up vote 2 down vote accepted

Displaying "ipaddress/Folder", meaning to list all files in the folder, requires Directory browsing permission for this folder. Directory browsing permission is off by default, as a security measure.

For Vista and above see Enable or Disable Directory Browsing in IIS 7 .

You do not need this permission for accessing a file via "ipaddress/Folder/file", but you then need to know the file's name in advance.

share|improve this answer
    
this worked perfectly thanks – cfarm54 Sep 14 '10 at 6:03

You might be able to use chmod if you're on Linux and give read access to all users, I'm not entirely sure though.

share|improve this answer
    
IIS is Windows only – Canadian Luke Feb 4 '12 at 18:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .