Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need to install a bios update to fix my PC after I upgraded the CPU. BIOS update should fix it.

But...

This seems to be way harder than it should be. I'd be great if motherboard manufacturers could provide bootable iso images with all the tools to do the job without us having the build these ourselves...

Anyway, how do I go about creating a freedos bootable CDR under Kubuntu that is BIGGER than 1.44 MB!

My image file is 1MB already. The flashing program 32KB. I tried the methods from the various forums and just couldn't get them to work. Either ran out of space, or all the links to fdos were broken.

by the way, www.fdos.org doesn't seem to be right anymore and thats where everyone is pointing. I would probably have had this sorted if I could have the 2.88 MB image, but all I can find is a 1.44MB image and I have now idea how you can grow that to a bigger one. Why be stuck with 1.44MB? are we still in the 1990's ????

Please help, I need step by step instructions.

share|improve this question
add comment

2 Answers

I believe this is what you are looking for. You might have to right click on the link to the freedos edition you want and then click "save as". Once you have the iso file, you can burn it to a CD using K3B by selecting the "burn image" option as described here under the kubuntu section.

share|improve this answer
    
Been there, done that. Even tried editing the livecd but the files were not loaded. why is this so hard? –  Matt H Sep 13 '10 at 22:23
    
@Matt Please include the link to the motherboard manufacturers BIOS update instructions and your motherboard make and model. –  James T Sep 13 '10 at 23:34
add comment
up vote 0 down vote accepted

To answer my own question. This is what I did to get it going in the end. I simply followed this pretty much to the letter and used a USB flash disk. Copied the bios and flash program to it.

http://forum-en.msi.com/index.php?topic=112158.0;prev_next=next

The bios and flash program are from shuttle. I have an SG31G2 version 1.2.

Once I booted into that, I was able to run awdflash and flash the bios with the new bios file.

Now I can actually run Virtual Box with VT extensions enabled which means I am now also running windows 7 64bit inside virtual box. Prior to the bios update the host would freeze.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.