Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two macs, running Leopard 10.5.8. One is the 13" MBP connected via WiFi, and the other is a 24" 2008 iMac, connected via ethernet.

There are at least another 6-10 machines (windows and mac) awake on the network (with shares) at any given time, yet there are plenty of times where I cannot see any devices/shares in either my "Shared" section in Finder, nor can I see any computers in "Network" in Finder.

Restarting doesn't help. I've restarted all the networking gear in the house to no avail.

Our network is a series of gigabit switches connected to a D-Link gaming router. I believe we use OpenDNS, and our provider is Cox.

I hate having to use "Go -> Connect to Server" to browse to commonly used file shares (by IP). I'd like to know why my shares do not always and consistently appear in Leopard.

Edit: I ran OnyX this morning, and performed the cleaning and maintenance operations (including disk permissions) on both my Macs, and at least one of my macs has started showing network devices again. (the other is still going). No idea how long this will last.

Any ideas as to what is causing this issue, and how to prevent it?

Edit 2: Aaaand there the shares go again. So running OnyX is not a permanent or reliable fix for this issue.

Edit 3: After a clean reinstall and update, network shares are still unreliable. The SMBClient command mentioned in comments shows me the information it's supposed to show, but the shares do not appear in the shared section. They'll also vanish at random and reappear at random throughout the day.

share|improve this question
    
I picked up this problem when I upgraded all my servers to Windows Server 2008. Still have not found a solution thought. –  Diago Aug 6 '09 at 6:40
    
Yeah. I've been looking as well. Our network consists of mostly Windows 7 PC's, as well as a few Windows XP machines (and of course the macs). –  EvilChookie Aug 6 '09 at 7:27
    
You may be able to diagnose the problem faster from the Terminal using the smb.../nmb... tools directly. For example, "smbclient -L name/IP" will list all known shares on Name/IP. "nmblookup" will attempt to find the IP for a Windows machine using samba. When the programs fail, they usually give you more information than the OS X gui will give you. –  Harvey Aug 10 '09 at 15:44
    
Forgot to mention, use "man smbclient" (or smbpasswd, etc.) to read up on how to use the programs. –  Harvey Aug 10 '09 at 15:46
    
Thanks for the info, Harvey. I ran those commands from Terminal, and got exactly what I expected out of it - everything is working fine. Of course, my shares are appearing, so that's not a problem. I'll see if it will fall over in the mean time, and hopefully your suggestion will give me some ideas as to what to do. Cheers –  EvilChookie Aug 10 '09 at 16:29

4 Answers 4

This is not an actual fix to your problem, but it should eliminate the headaches that you are experiencing.

A. Create a folder called "Network Shares" or somewhere in your user directory or possibly in a shared directory. Drag this directory to the finder sidebar under Places.

B. Do the following for each share that you want to connect to routinely:

  1. Use Command-K from finder to mount the shared volume. This should add the server under shared in the finder sidebar
  2. Go to System Preferences -> Acoounts (Under System), select your account and open the login items tab.
  3. Click the plus button under login items and navigate to the share that you want to connect to.
  4. This gets a little tricky here. For some reason, you cannot create an alias in finder (Command-Option Click and drag) to network shares, you can do this to any directory under the network share, but not the share itself, so if you want the share itself accessible as an alias, you have to use the terminal to create a symlink which is essentially the same thing. If you need to do the symlink thing here are the steps.
  5. Make sure that the share is mounted.
  6. Open terminal.
  7. Navigate tothe folder you created, Network Shares (if you created this folder directly under your home folder the command is cd ~/"Network Shares"/.
  8. create the symlink :ln -s /Volumes/"Share Name" "Name of alias file" (the quotes aren't necessary if there are no spaces in the file name.

What you end up with is a folder full of aliases that point to all the shares you access frequently.

share|improve this answer
    
While I appreciate it's a valid work around, I would prefer not to have to do this, as it doesn't fix the underlying problem. –  EvilChookie Aug 9 '09 at 20:27
    
I understand your desire to find and fix the underlying problem - I suggest opening a support ticket with Apple and or posting on their forums. –  Scott Aug 10 '09 at 3:18

One more thing to check: Is your firewall turned on in the Mac's System Preferences?

This probably isn't your problem since you also have an iMac. Rarely I will find myself at a coffee shop with free WiFi and I'll immediately turn on the firewall. I inevitably return to work and then complain for a week that none of the computers on the network appear in my shared list. Eventually, I remember the firewall and problem solved.

share|improve this answer
    
No, it's definitely not on. –  EvilChookie Aug 10 '09 at 16:21

Another possible solution: Use a WINS Server

Setup one machine (Windows, Mac, your router, etc.) to be the domain master and configure your Macs to use it by setting the WINS Server setting under the Advanced Network Settings in System Preferences. (Note: The software firewall will block this solution)

share|improve this answer

The problem is caused by a Windows 7 computer acting as the Master Browser for the network. The solution was to disable the Computer Browser service on all computers in the network running Windows 7. In my case, I used a Windows XP computer as the browser (and then later, a Linux server running Samba)

I believe the output created by a Windows 7 master browser is not compatible with Leopard.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.