Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This kind of feature is available in eclipse and lots of other IDEs, why doesn't it exist in visual studio?

Or it needs to be enabled somewhere?

share|improve this question

It does exist but there are two issues with it.

  • you need to be in-front of opening brace ({) or after closing brace (})
  • color is gray and thus not really visible
share|improve this answer
Is there a patch for it? – fms Sep 13 '10 at 15:58
&http: This is by design. :( – Josip Medved Sep 13 '10 at 18:48
You can change the color – surfasb Jul 22 '11 at 21:27

I just tested in Visual Studio Express 2008 (Visual C++). When I type a brace, it will bold the brace I just typed and its matching brace. It doesn't do anything when I move the text cursor past braces.

To make sure this feature is on, go to Tools, Options, Text Editor, General, and check Automatic delimiter highlighting. (Besides braces, it also highlights other pairs like parentheses, brackets, and #ifdef and #endif pairs.)

You can change the brace matching highlight appearance in Tools, Options, Environment, Fonts and Colors, Show settings for: Text Editor, Display items: Brace Matching (Highlight).

According to Automatic Brace Matching, highlighting matching braces when the text cursor moves past a brace is only available in Visual C#. In that case, you can change the matching highlight appearance by going the same place as above and modifying the Brace Matching (Rectangle) item.

If you aren't using C#, you can just backspace and re-type the brace to achieve a similar effect. Alternatively, you can press Ctrl+] to move between the matching braces.

share|improve this answer

Remember to close and reopen visual studio after you make the change in Tools -> Options..

I'm working with MS Express Windows Phone and couldn't figure out why changing the setting wasn't working..

Just save, close, reopen MS Studio

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .