Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Dell OptiPlex 360 workstation at work, with 2 x ATI RV280 [Radeon 9200 PRO] graphics cards installed, which are attached to two identical 19" HII flat panel monitors. I'm using the open source Radeon driver with Ubuntu, and the proprietary drivers with Windows. The good news is that dual head configuration works for both OSes. The bad news is, I have to use a different hardware configuration for each OS to achieve this.

Hardware config #1: Dual monitors work for Windows XP Pro like this:

First display -> external VGA port
Second display -> DVI input on gfx card

Hardware config #2: Dual monitors work for Ubuntu 10.04.1 like this:

First display -> VGA port on gfx card
Second display -> DVI input on gfx card

I connected up the displays according to Config #2 and booted up Windows, which resulted in a mirror image on both screens. I was unable to login, as the login box was not visible. I unplugged the VGA lead from gfx card and plugged it into the external VGA port (Config #1) - Windows dual head works again, but the VGA-connected screen is not recognised by Ubuntu and remains in standby mode. Is it possible to configure a dual head setup for Ubuntu using Config #1, or am I missing something?

I tried setting up dual monitors using Config #1, this morning which didn't work. By default, there is no xorg.conf file in Ubuntu 10.04.1, so I generated one using:

$ sudo X :2 -configure

X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-27-server i686 Ubuntu
Current Operating System: Linux harrier 2.6.32-24-generic #42-Ubuntu SMP Fri Aug 20 14:24:04 UTC 2010 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-24-generic root=UUID=a34c1931-98d4-4a34-880c-c227a2936c4a ro quiet splash
Build Date: 21 July 2010  12:47:34PM
xorg-server 2:1.7.6-2ubuntu7.3 (For technical support please see
Current version of pixman: 0.16.4
    Before reporting problems, check
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.2.log", Time: Mon Sep 13 10:02:02 2010
List of video drivers:
(++) Using config file: "/home/michael/"
(==) Using config directory: "/usr/lib/X11/xorg.conf.d"
(II) [KMS] No DRICreatePCIBusID symbol, no kernel modesetting.

Xorg detected your mouse at device /dev/input/mice.
Please check your config if the mouse is still not
operational, as by default Xorg tries to autodetect
the protocol.

Xorg has configured a multihead system, please check your config.

Your xorg.conf file is /home/michael/

To test the server, run 'X -config /home/michael/'

ddxSigGiveUp: Closing log

$ sudo X -config /home/michael/

Fatal server error:

Server is already active for display 0

    If this server is no longer running, remove /tmp/.X0-lock

    and start again.

Please consult the The X.Org Foundation support


for help.

ddxSigGiveUp: Closing log

I then booted Ubuntu in failsafe mode, dropped into root shell, and executed $ X -config /home/michael/ again. The screen went blank and turned off, so

share|improve this question
What exactly is the difference between "external VGA port" and "VGA port on graphics card"? Dou you have a VGA connector that is not on one of your graphics cards? –  Olfan Sep 13 '10 at 16:39
It's probably possible: X allows many complex setups, and Radeon 9xxx cards are particularly well supported. Your setup is complex enough that it may take some hand-tuning of configuration file, though. Please post the generated so that people may suggest changes. Like Olfan, I wonder what you mean by “external VGA port”: do you have a Radeon 9200pro graphics chip on your motherboard plus a separate Radeon 9200pro graphics card? –  Gilles Sep 13 '10 at 19:00
A few tips when testing: If you see a black screen that doesn't go away after a few seconds, try pressing Ctrl+Alt+Backspace to kill the X server. Test with sudo X -config /home/michael/ :2 to avoid having to boot in failsafe mode, or (better, because occasionally running two X servers accessing multiple cards with different configurations doesn't work well) kill the X server that's already running (log out of graphic mode then run service gdm stop). –  Gilles Sep 13 '10 at 19:03
Apologies for confusion - my hardware knowledge is limited. To clarify, by 'external VGA port', I mean the VGA port that is situated within the main array of mainboard inputs. I'm not sure of the technical term for this particular input? As opposed to the second VGA port that is situated on the gfx card. Does this suggest that the system has a Radeon 9200pro graphics chip on the motherboard and Radeon 9200pro graphics card? –  mejpark Sep 13 '10 at 20:21
Here's /home/michael/ –  mejpark Sep 13 '10 at 20:33

1 Answer 1

I managed to solve the problem by setting up the monitors according to config #2, then booting into Windows and experimenting with the graphics configuration using the ATI Conrol Centre application. This was much easier than writing an xorg.conf from scratch. I don't know why I didn't think of this sooner!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.