Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here's how it's going:

host> echo "Hey my man" | mail -s "Testing" myaddress@gmail.com

Then, in /var/log/mail.log:

Sep 13 12:08:31 host postfix/pickup[738]: EB0535EF3F3: uid=501 from=<user>
Sep 13 12:08:31 host postfix/cleanup[753]: EB0535EF3F3: message-id=<20100913190831.EB0535EF3F3@host.local>
Sep 13 12:08:31 host postfix/qmgr[739]: EB0535EF3F3: from=<user@host.local>, size=309, nrcpt=1 (queue active)
Sep 13 12:08:32 host postfix/smtp[755]: connect to gmail-smtp-in.l.google.com[]:25: Host is down
Sep 13 12:08:32 host postfix/smtp[755]: connect to alt1.gmail-smtp-in.l.google.com[]:25: Host is down
Sep 13 12:08:32 host postfix/smtp[755]: connect to alt2.gmail-smtp-in.l.google.com[]:25: Host is down
Sep 13 12:08:32 host postfix/smtp[755]: connect to alt3.gmail-smtp-in.l.google.com[]:25: Host is down
Sep 13 12:08:32 host postfix/smtp[755]: connect to alt4.gmail-smtp-in.l.google.com[]:25: Host is down
Sep 13 12:08:32 host postfix/smtp[755]: EB0535EF3F3: to=<myaddress@gmail.com>, relay=none, delay=0.22, delays=0.02/0.01/0.19/0, dsn=4.4.1, status=deferred (connect to alt4.gmail-smtp-in.l.google.com[]:25: Host is down)

Uh, really? Gmail is down? Not really: it works from my various mail applications, etc. running dig alt4.gmail-smtp-in.l.google.com yields:

; <<>> DiG 9.6.0-APPLE-P2 <<>> alt4.gmail-smtp-in.l.google.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57897
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 4, ADDITIONAL: 4

;alt4.gmail-smtp-in.l.google.com. IN    A

alt4.gmail-smtp-in.l.google.com. 168 IN A

google.com.             567     IN      NS      ns1.google.com.
google.com.             567     IN      NS      ns4.google.com.
google.com.             567     IN      NS      ns3.google.com.
google.com.             567     IN      NS      ns2.google.com.

ns1.google.com.         768     IN      A
ns2.google.com.         657     IN      A
ns3.google.com.         867     IN      A
ns4.google.com.         598     IN      A

;; Query time: 14 msec
;; WHEN: Mon Sep 13 12:08:43 2010
;; MSG SIZE  rcvd: 201

Looks good to me. I tried my Google Apps account and received:

Sep 13 12:26:16 host postfix/smtp[1160]: connect to ASPMX.L.GOOGLE.COM[]:25: Host is down
Sep 13 12:26:16 host postfix/smtp[1160]: BB2655EF5D7: to=<user@domain.com>, relay=none, delay=5.1, delays=0.01/0.01/5.1/0, dsn=4.4.1, status=deferred (connect to ASPMX.L.GOOGLE.COM[]:25: Host is down)

But of course it's not down. This is a stock Snow Leopard install- haven't toyed w/ the postfix configuration files or anything. I need mail to work for cron job-related mails and this is driving me nuts.

Any ideas? There's also this damning bit of evidence:

host> telnet aspmx.l.google.com 25
telnet: connect to address Host is down
telnet: Unable to connect to remote host

Is there something being filtered at my ISP level, or what?

share|improve this question
Who is your ISP? Some ISPs do block port 25. –  Chealion Sep 13 '10 at 21:06
It's Cox. I'm guessing that's what is going on. Now I need to figure out how to get around that. –  Wells Sep 13 '10 at 23:39
I'd like to mumble something incoherent about how port 587 is the preferred port for mail submission nowadays. –  Spiff Sep 14 '10 at 9:10

2 Answers 2

up vote 0 down vote accepted

ISPs that block outgoing connections on port 25 generally provide an outgoing server that you can relay mail through (and where they can apply their spam filters to make sure you aren't doing anything nasty). According to this article, you need to relay through either smtp.west.cox.net or smtp.east.cox.net, depending on which state you're in. To do this, edit /etc/postfix/main.cf and add a line like this:

relayhost = [smtp.west.cox.net]
share|improve this answer
I tried that. Same result unfortunately: 11A5B5F3925: to=<user@mydomain.net>, relay=none, delay=1168, delays=1168/0.02/0.04/0, dsn=4.4.1, status=deferred (connect to smtp.west.cox.net[]:25: Host is down) –  Wells Sep 14 '10 at 17:08

Are you attempting an unencrypted connection to GMail, which would either expose a password or expect GMail to deliver a message without authentication?

Doubt that's gonna work.

See http://mail.google.com/support/bin/answer.py?hl=en&answer=78775 which talks about SSL being needed.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.