Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've done the usual edit of /etc/sysctl.conf to include the parameter, but it just tosses errors. I haven't had to tune a kernel in a very long time, what's different about it nowadays (or have I simply forgotten how)?

edit:

Added "kernel.semmni = 2048" to the tail of /etc/sysctl.conf and then ran "sysctl -p". End result is an unknown key error (apparently kernel.semmni isn't the valid name anymore?).

share|improve this question
    
OK, this doesn't work under Oracle Enterprise Linux either. There's got to be a way to change the number of system wide semaphores available, the default 128 is ridiculously low. Any more ideas? – Brian Knoblauch Sep 24 '10 at 13:04
up vote 2 down vote accepted

Finally got it. Desipite what everything I found on Google suggested, semaphores aren't individually settable, they're all bundled together under "kernel.sem". Added:

kernel.sem=250 32000 100 2048

to my /etc/sysctl.conf and I'm in business!

share|improve this answer

You can see the list of valid sysctl params with sysctl -a. I'd run that, see if it's changed in your newer kernel

share|improve this answer
    
Helpful, I was completely overlooking that option. "semmni" is not a valid option on this kernel. Rather unfortunate, since the software I'm trying to install says that I need to bump it from 128 up to 2048... Argh. – Brian Knoblauch Sep 14 '10 at 15:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .