Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My roommate and I are experiencing a problem in that our computers have the same IP address. I have a laptop and he's got a desktop, and only recently did this occur, in the past day or two.

Is there a way to reset our ip addresses? What can we do?

share|improve this question

migrated from Sep 13 '10 at 22:47

This question came from our site for professional and enthusiast programmers.

Try changing your IP address settings to auto. If using Windows 7, run the Network Troubleshooter. – SimpleCoder Sep 13 '10 at 22:40
"Is there a way to reset our ip addresses?" Usually. However, with no facts available in the question, there's no way we can answer. Unless someone is psychic and somehow magically know what your network, hardware, software and computers really are. – S.Lott Sep 13 '10 at 22:40
ipconfig /renew – Marko Ivanovski Sep 13 '10 at 22:40
ipconfig /renew didn't do anything – Daniel Sep 13 '10 at 22:42
What operating systems do you use? Did either of you do any specific networking configuration? Did you try rebooting, or at least unplugging from the network and plugging back in? What is your network setup (e.g. both connected to <router brand> configured <so>)? – Gilles Sep 13 '10 at 22:53

This may be a silly question but...

Are you referring to INTERNAL or EXTERNAL IP address? I don't see it mentioned anywhere else here, but you will 100% of the time have the SAME EXTERNAL IP if you are on the same router. What indication did you have that you are on the same IP address?

share|improve this answer
Its often the obvious question no-one asks. My bet is a check on will have shown up the external. Nice question / answer – Joe Taylor Sep 14 '10 at 14:29

Just to rule out a basic misconfiguration, go to the command prompt and type

ipconfig /renew

if this doesn't fix it then, go to Network Connections (Vista/7 go to Network and sharing Center then click Change adapter settings on the left or in XP, go to Control Panel > Network Connections).

Now, right click on the adapter you are using and find 'Internet Protocol Version 4 (TCP/IPv4)`.

Make sure automatic is set for at least the top one and your alternate configuration, unless you have a reason to have it manually set.

alt text

If there is a reason you need a manual address (Such as no DHCP source), consider simply changing the last number in the IP to something that no other device is using.

share|improve this answer

From the command prompt type

ipconfig /release

followed by

ipconfig /renew

If that doesn't work, check that you don't have a manually set ip address on one of the machines

You may also be running into an issue where only 1 ip address is given for a port. If you're on a campus, the administrator may be limiting the number of IP addresses used. If you're on a broadband connect, make sure you're using a router with NAT and DHCP and not just a hub.

If you are using a router, it may have partially died on you.

share|improve this answer
That didn't work, we shouldn't have any manual ip addresses. – Daniel Sep 13 '10 at 23:08
The router is new, is there any way to check? – Daniel Sep 13 '10 at 23:08
1. What addresses are you getting? That can help identify the problem. 2. Have you done anything to configure the router? – Brad Bruce Sep 13 '10 at 23:58

Ok, I'm assuming you're using NAT and DHCP on some cheap home router. This is VERY VERY common on these devices. There are two surefire fixes. One is to statically assign them addresses using the router (see router manual to configure static addresses based on MAC address) or you can statically assign IP addresses within the DHCP range in the computers themselves.

ipconfig /release and /renew will usually not work without clearing the ARP cache out, and this is often times not an option through the GUI on home routers.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.