Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was having problems with Visual Studio editing ASPX pages and read on stackoverflow.com that you could just uninstall the Web Authoring Component and it would fix that problem. I couldn't uninstall it because of a registry permission issue saying:

Office Error:

alt text

I used the Windows Install Clean Up utility to try to remove it.

Bad idea. It totally broke my office.

When I tried to uninstall, then reinstall office: It took me hours to figure out that (I'm pretty sure) Office was trying to use my dvd-rom drive as the local cache so i had to run the setup with this parameter which makes office install ignoring all previous settings:

setup.exe oem_noprevious=1

(I do a mini celebration because it starts copying files)

[LOTS OF CURSING] I get the same error when re-installing as when I was trying to uninstall it (see the image above)

I go into my registry, seek out that key. Turns out even if I run regedit.exe as administrator I still do not have permission to access and change permissions on said key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Components\80F8A534CE34C37479A36408DF607B90\9040211900063D11C8EF10054038389C

I am looking for suggestions on how to have full control over the registry or delete a (possibly) corrupt key because I cannot modify the permissions on that key or delete it. Or any other office re-install suggestions would be fantastic.

share|improve this question

migrated from serverfault.com Sep 14 '10 at 6:44

This question came from our site for professional system and network administrators.

2 Answers 2

Blow away your user profile. It is extreme, but it should work.

Also create an admin install point it gives you some more options (and can avoid the whole local cache issue) http://office.microsoft.com/en-us/office-2003-resource-kit/creating-an-administrative-installation-point-HA001140193.aspx

share|improve this answer
    
I'm using a retail version of office so I can't create an admin install point. I would like to avoid blowing away the entire user profile because I've got a lot of other installed programs on this computer since it's my development machine. However if that's the only solution I may bite the bullet. –  Fake Jun 24 '10 at 20:08
    
Oh right, sorry too used to dealing with the enterprise edition. It won't mess with your installed programs just per user settings, annoying, but not life killing. Have you tried just changing permisions? social.answers.microsoft.com/Forums/en-US/vistaprograms/thread/… –  yasth Jun 24 '10 at 21:37
    
I have tried changing permissions, however I don't have permission to even change permissions on the key, or delete it. I tried changing the permissions on the parent key, hoping that the key in question would inherit the permissions but that didn't work. I also tried taking ownership of the key but I don't have permission on the key to do anything. I even logged in as the built in administrator account. I'll try deleting the user profile next monday if nobody else has a solution for changing permissions on that registry key. –  Fake Jun 24 '10 at 21:41
    
Well... I tried deleting the user profile and I'm still getting the same registry error. Must not have deleted that key when I deleted the user profile. This is pretty ridiculous. –  Fake Jun 28 '10 at 14:13
    
So I basically reformatted my computer because I couldn't get any answers on getting rid of that key and I need to have office installed. –  Fake Jun 30 '10 at 15:02

It happened to me once that I couldn't remove a registry key because of permission issues, and I couldn't change the permissions on that node for some unknown reasons.

What I did is select the parent node of the node I wanted to remove, then set the permissions so that my user could delete that node. Then I selected the option to make the children nodes inherit those permissions. That did the trick: I could select just the node I wanted to get rid of, and delete it.

So, give it a try.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.