Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I create a shortcut to a file or folder in Vista, I'd like it to not automatically append " - Shortcut" to the name of the shortcut.

For example:

  1. Create a shortcut to the "Foo" application.
  2. Shortcut gets named "Foo - Shortcut".
  3. I then have to manually remove the " - Shortcut" from the name.

Ideally, I'd like to avoid having to do step #3 every time I make a shortcut.

How can I do this?

share|improve this question
up vote 11 down vote accepted

Microsoft has not released a Vista specific version of TweakUI, but Microsoft MVP Ramesh Kumar has written an unofficial one called Ultimate Windows Tweaker that can do what you want in a user-friendly way (ie no registry hacking). The option you want is under Additional Tweaks -> Remove “-Shortcut to”…

share|improve this answer
2  
And for Windows XP indeed, TweakUI has this option (if a XP user was checking this question..) – Gnoupi Aug 6 '09 at 15:28
    
Actually, I had originally included a link to TweakUI XP. But this question is in reference specifically to the Vista version, which uses a different label in the shortcut: “- Shortcut” instead of “Shortcut to”. So I ended up deleting that part of the answer. I guess I could roll-back. – Synetech Aug 6 '09 at 15:30
    
No, I think it's good like this, the main answer is about the question, under Vista, so. The XP fact is more matching to the simple comment. – Gnoupi Aug 6 '09 at 16:01
    
UWT also works for Windows 7 and is available from The Windows Club in addition to Ramesh’s site. – Synetech Feb 19 '11 at 20:25

There's a simple registry hack you can do for this, which I've provided a downloadable reg hack file for. It says Vista, but it should work across the board.

Remove "Shortcut" Text From New Shortcuts in Vista

alt text

share|improve this answer
1  
I think I linked to your solution in another question as well ;-) – Ivo Flipse Aug 6 '09 at 6:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .