Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having an infuriating issue.

At the moment I can set up a VPN connection through the "New Connection Wizard" but it just doesn't show up anywhere. If i look at the "network connections" screen all I see is "LAN or High-Speed Internet" and "Wizard". Neither of which have any of the VPN connections I've tried to set up underneath them.

I have noticed that under my services that the "Routing and Remote Access" service isn't started. When I start it, it fails with an error of 0x80004005 (according to the system log) which appears to be a "generic" error.

Has anyone got any ideas on how I can fix this problem as it is seriously hampering my ability to test out some networking software I've written across a VPN :(

Edit: Well thanks to Ian Boyd I can now get a VPN connection. If anyone has any ideas on how to make my VPN connections actually appear under windows however, I'd still really like to know!

share|improve this question
add comment

4 Answers 4

up vote 1 down vote accepted

i would suggest running rasdial from a command prompt. What do you see?

i had an issue similar sounding to this, which i posted on Microsoft's forums. i'll cross-post here, since this board is much better.

Note: These screenshots were from Windows Vista. Windows 7 doesn't include a screen where you can see your connections. All you get in Windows 7 is the pop-up window available through the notification area icon.


VPN connections disappear, RASDIAL makes them reappear

Here's a screenshot of the Connect to a Network dialog. Notice my VPN connection doesn't show. Nothing shows:

alt text

In order to get the dialog to regain its senses, i simply drop to an elevated command prompt, and run

rasdial [Name of the VPN connection]

You don't need the credentials. You don't need it to sucessfully connect; you just need to poke rasdial with a stick:

alt text

Now the Connect to a Network dialog works:

alt text

You are seeing screenshots from Windows Vista. i have also seen this bug on Windows XP.

share|improve this answer
    
rasdial says "No Connections" and "Command completed successfully." Alas no improvement ... –  Goz Sep 14 '10 at 11:36
    
while not being a muppet typing "rasdial test1" returns "Remote Access error 623 - The system could not find the phone book entry for this connection." –  Goz Sep 14 '10 at 11:37
    
oh god. I'm being more of a muppet ... I forgot to click finish ... Now it does "Connecting to TEST1... Verifying username and password... Remote Access error 691 - Access was denied because the username and/or password was invalid on the domain." –  Goz Sep 14 '10 at 11:38
    
STill doesn't show up in the network connections box though ... –  Goz Sep 14 '10 at 11:39
    
Going back in time, i remember that you have to type the name of the connection that already exists. i realize you can't see the name anywhere, but that's the cross that we must bear :) –  Ian Boyd Sep 14 '10 at 11:40
show 4 more comments

Routing and Remote Access service is only needed on the server in order for clients to connect in, not on the client.

As for it not showing up, are you running the wizard through until completion? Unless you check the "do not connect now" option, and you do not allow it to connect then, it will not save the connection.

FYI, it may not help you now, but if you are the sysadmin and want to make sure everything is ok on the server as well, I wrote a blog post not long ago on how to set up Windows VPN on the server very fast. Link.

share|improve this answer
    
Well I'm trying to connect to a PPTP server I'm running on an ubuntu box. I can connect with an iPhone, Mac OSX, Several win 7 and XP machines just NOT my development machine. When I run the wizard I get to the last screen and tell it to add a shortcut to my desktop and click finish and then nothing happens. The connection doesn't show up on the desktop or in the network connections. Thing is if i try and re-create the VPN afterwards using the same name then it complains that it already exists ... It won't allow me to connect to it though ... –  Goz Sep 14 '10 at 11:33
    
@Goz sorry, out of ideas, I usually use VPN hardware, only very recently started using native Windows VPN. I would say just try pressing F5 / refresh in the network connections windows. I hope you get an answer. –  William Hilsum Sep 14 '10 at 11:41
add comment

I was able to see my vpn connections only when I clicked on the "Change Adapter Settings" link on the right side of the Network and Sharing Center dialog.

share|improve this answer
add comment

I had a same problem! Trouble was in incorrect disk quotas or disk is completely full! May be to much file system errors.... It's necessary to check file system integrity and free some space may be make disk defragmentation...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.