Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Under Windows XP/32, I have configured files without an extesions, such as README, to be opened by:

C:\Programme\Emacs\bin\emacsclientw.exe -n "%1"

I used the guide available at the following URL:

http://www.winhelponline.com/articles/67/1/How-to-associate-Notepad-to-open-files-with-no-extension.html

Now, this works fine on local drives. However, on network drives, Windows Explorer alway gives me a warning. Something like: The file type is unknown and it may be unsafe to open it. (Original is in German)

Note that I access the share by its netbios name. And two more things:

  • Opening e.g. a .txt file works fine. No prompt.

  • The default program for opening extension-less files on the share is not EMACS, as for the local share. It is some other random text editor, "Rex".

How do I get rid of that warning?

Update

I was able to solve the problem with files being opened in "Rex" instead of EMACS. Concerning how to properly set up associations for files without extension: Take a look at the page on Win32 file associations on EmacsWiki, which I amended.

share|improve this question

1 Answer 1

This is nothing specific about your setup / configuration. I have copied an answer I wrote for: Trusting files on my NAS in XP


Go to Internet Options either through Control Panel or Internet Explorer and under the Security tab, you need to add the IP address of the nas in to the Trusted Zones list.

After this, click Custom level... and under Launching applications and unsafe files, change it to Enable.

You can also do this on the Internet Zone, however this is potentially dangerous as it gives pretty much everything those permissions. By doing it to the Trusted sites zone, we are only giving this to the sites you put in the zone.

alt text

Now this should hopefully stop the warning message.

share|improve this answer
    
Thanks for the suggestion, Wil. However, so far it didn't work! I added the Internet domain name to the trusted sites. That domain name is as entered in c:\windows\system32\drivers\etc\hosts. And I changed the Security Settings as described. I also tried out security level "very Low". –  feklee Sep 14 '10 at 17:34
    
Also note the details that I just added to my question. –  feklee Sep 14 '10 at 17:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.