Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Guys, this problem seems to be common, but I can't find the solution.

The internal microphone in my Ubuntu 10.04 is not working, though it works pretty fine in Windows. My laptop is ThinkPad Edge 13.0 (Intel). I've tried a couple of solutions so far:

  1. Killing the pulseaudio
  2. Changing the values in alsamixer
  3. Changing the values in the default volume control

I tested recording with either standard Sound recorder in Ubuntu and also the following command: arecord -vv -fdat foo.wav

Everything fails.

What would you recommend me to do instead of buying the external microphone (it's not reallt good for me, because my current headphones are without the microphone and I'd better work with them.

Will be happy to get some help with it! Thanks

share|improve this question
Should be on – altCognito Sep 15 '10 at 17:16
I'm posting here because I have the same problem on a Lenovo S10. – tj111 Sep 16 '10 at 18:01

The solution was in downgrading to the kernel 2.6.32-24-generic-pae

share|improve this answer
Okay, it seemed not to be a real solution, because with the internal microphone working fine the external speakers don't work. Sound keeps streaming though the internal ones. Anyone know the solution? – lyuba Sep 16 '10 at 17:25

This is what I had to do to get the microphone to work on my girlfriends Acer Aspire One:

  1. Install pavucontrol (sudo apt-get install pavucontrol)
  2. Run pavucontrol
  3. Go to the "Input Devices" tab
  4. Click the icon to unlock the channels
  5. Set the right-front channel to silence.

I dunno if that will work for you or not, just something that has worked for me in the past.

share|improve this answer
It doesn't help, unfortunately.. ( – lyuba Sep 17 '10 at 13:53
Didn't think it would (didn't work on my S10), but figured it was worth a shot. – tj111 Sep 17 '10 at 14:12

I had recently tried to resolve this same issue on my own laptop (Ubuntu 10.04 32-bit). It turned out I needed to select "Microphone 2" on the "Connector" dropdown under the "Input" tab in "Sound Preferences". My extrapolation for your situation (which might not work anyway) is to try each of the selections in that "Connector" dropdown and (hopefully) find one that works. It's muffled-sounding now, but better than nothing :-\

In any case, good luck!

share|improve this answer
Thing is that I don't even have my internal microphone as the option in those dropdown. After some of my recent manipulations of trying to fix this, the Input tab is now completely empty... ( – lyuba Sep 20 '10 at 11:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .