Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a WD Sharespace storage device at home. link

I currently backup my live servers files to a PC of mine at home.
I do this once daily using RoboCopy and a scheduled task.
I use this robocopy command so only new files are copied daily:

robocopy \\serverip\share\backupfolder c:\backups /E

I want to take this one step further and also back this up daily from my PC to my WD Sharespace storage device.
The problem i'm having is this won't copy only the new files.
Everytime I run this it copies every file again as if its changed.
I assumed the NAS device may be changing the modified time but it seems to remain the same.

I have tried to use XCOPY which does the exact same thing.
What is causing this and how can i set this up to only copy new files?

Note: These are pretty much daily document and database backups. This files will actually never be changed but only new files will be added daily.

share|improve this question
up vote 3 down vote accepted

If you are having problems, you may want to take a look at Microsoft Synctoy

If you want to stick with Robocopy, try adding the /XO option which is (from the help file) /XO :: eXclude Older files.

share|improve this answer
    
I had actually tried the /XO options. It still constantly thinks some files are "newer". Syntoy looks like a winner though! thanks – WebDude Sep 14 '10 at 19:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .