Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

One of my friends receives her internet from her apartment complex and certain network applications (MapTool and World of Warcraft) cause problems with connecting to other servers. She is able to find the server and connect but then almost immediately is disconnected from the server.

I asked the people on the MapTool forum about this problem but they were unable to help and so I thought, since it is happening for WoW as well, that there might be a bigger problem.

Obviously, since she gets her network from the apartment complex she has no access to the router to change or edit any settings on it, but she does have admin access to her own laptop.

She has an HP Laptop running Windows 7. She has very little computer experience although I have been able to walk her through some things in the past and so could do so again.

Also of note is that some network applications do work, Neverwinter Nights as well as a rather simple C# application that I wrote so the router is selectively blocking things.

Lastly, if I set MapTool (which runs a server on my local machine) to use the port that Neverwinter Nights uses it still fails.

EDIT: Its important to note that its not the ports that are the problem as I mentioned above, she cannot connect to my MapTool server even if I use the same port as Neverwinter Nights (which she can connect to). Also the WoW updater uses the same ports as WoW and that works just fine. So it is something else.

Also, she uses McAfee firewall with the Windows 7 Firewall disabled, but even when she disabled the McAfee there she was still unable to connect, so again its not that.

Second Edit: This problem is fixed, she brought her computer somewhere and had it looked at (it was a problem with her computer and not the network). I asked what the problem was but she said she kind of zoned out when they went technical so I guess we will never know.

share|improve this question
Can you provide a little bit more specific information about the actual network setup and the services you are trying to use? I think you are talking about two different things when you refer to connecting to ports, and you haven't clearly distinguished between inbound and outbound connections. If you're connecting to an external server running eg Maptools, you can't set the port to use (unless you've also configured and run the server yourself) so your comment about using the same port as NWN doesn't seem to make sense. – imoatama Sep 15 '10 at 14:43
I am diagnosing a problem for a friend of mine. She is trying to connect to a server that I am hosting. My computer is set up properly (meaning other people can connect to it) but when she tries to connect it just immediately disconnects her. The reason I don't believe its a port problem is that as I said when I set the port on my computer to the same ports that she can connect to using Neverwinter Nights she still has the same issue. Am I making myself clear now? If not I can try and draw a diagram and post it. – James J. Regan IV Sep 16 '10 at 17:31

IP tunnels. What you want is to take the blocked traffic and hide it inside of a "tunnel" that looks like allowed traffic to the firewall/router. Assuming SSH is allowed, use Putty to tunnel, say, the WoW traffic, through an SSH tunnel. The setup may be too slow, but seeing for yourself is a fun way to find out.

An instance of using PuTTY...

share|improve this answer
Also Best diagram I've seen explaining tunnels... Tool that may render your quest much more convenient... SSH tunnelling applied to blocked git servers...… – composer Sep 14 '10 at 23:53
I would rather not deal with SSH tunneling if there was another option, it seems rather complicated for this, especially considering that (as I said) some network traffic is allowed while others is not. – James J. Regan IV Sep 15 '10 at 2:10
Tunneling didn't work, I set it up (I think correctly) following the souptonuts tutorial and when she tried to log in to WoW she got the same error as before. – James J. Regan IV Sep 19 '10 at 4:47

If the connection truly is restricted ie some ports are blocked, you'll have to "tunnel" it over one of the allowed ports. This sort of functionality can be provided by SSH tunnels or by VPNS.

Hamachi is an example of a VPN provider that would do this for you - just make sure that 'the internet' and whatever you're trying to connect to see your Hamachi address not you ISP WAN address. To do this you need to make sure that outbound traffic prefers the Hamachi interface, which you can do by setting the priority of your network connections.

Depending on how MapTool/ WoW work it may be that the net connection isn't actually restricted, but that it implements a crippled form of NAT, that doesn't support what you need to do. Or if you're trying to setup a server to accept inbound connections (ie connection initiated by others, not you), you'd need to setup port forwarding for things to work which obviously isn't possible here. In any case, using tunneling is the most likely means to succeed.

share|improve this answer
We did get it working using Hamachi, although I think there was some other issues with that as well, because she kept getting disconnected (although without letting her know this time). Also, it is not on my end, I had other people who could connect to my server no problem, and World of Warcraft obviously can accept inbound connections. – James J. Regan IV Sep 15 '10 at 4:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .