Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed FreeBSD 8.1 on a VM and I can't seem to get the internet connection working. I get to the networking part of the installation and it first checks for ipv6 support and then checks for DHCP, this is all on the em0 interface. It then comes up to a screen for me to enter a hostname, dns, ipv4 address. The thing is, how am I supposed to know these?

Anyone who has installed FreeBSD on VMWare Workstation please can you help.

Thanks.

share|improve this question
    
Poor emo interface :( –  John T Sep 15 '10 at 2:19

2 Answers 2

up vote 1 down vote accepted

I use a different VM instead of VMWare but I do have FreeBSD 8.1(64) working. I used the NAT interface (default for VBox) and asked for BSD to try DHCP. BSD apparently picked up an address but still went on to the "give me a specific IP" page. I canceled out of that page and when I looked at ifconfig em0 it had a 10.x.x.x address, was active and I can use ssh from the VM'd FreeBSD to get to other systems on the internet.

VMWare might be a little different but I think the general principles should apply.

PS: I did the original install without networking and then went back separately to configure it with sysinstall.

share|improve this answer

Ensure the VM network settings for FreeBSD are in bridged mode and the VM will pick up an address over DHCP, assuming you have an operational DHCP server on the network.

If you've gotten past the install already, you can run dhclient from the command line to make a DHCP request.

To keep it persistent across reboots, add it to your /etc/rc.conf:

echo ifconfig_em0=\"DHCP\" >> /etc/rc.conf
share|improve this answer
    
I have got the vm in bridged mode and I am connected to a wireless router with DHCP but it isn't providing me settings. –  Sandeep Bansal Sep 15 '10 at 11:17
1  
You should REALLY state things like that in the question. Wireless is going to change this whole situation around. Since your wifi is most likely password protected, you're going to have to follow some steps to get it going: freebsd.org/doc/handbook/network-wireless.html . I initially assumed you were wired into a router, in that case my previous answer would work. –  John T Sep 15 '10 at 22:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.