Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use urxvt with GNU screen with X11 on my mac. I like it a lot. My only issue, is that when I quit vim, it puts the shell prompt underneath the vim window. This isn't a huge issue, but it basically hides whatever I was doing before I opened vim. If I use urxvt without GNU screen and quit vim, it hides the vim window and puts my shell prompt right after the prompt that opened vim.

Any idea as to what I can fix in screen to help with this?

Does this have something to do with the screen blanker?

share|improve this question
add comment

3 Answers 3

up vote 10 down vote accepted

Enable the altscreen option in ~/.screenrc.

Full-screen programs use a feature of xterm (and compatible) called "alternate screen", which has a separate screen buffer and (often) minor behavior changes to adapt to such interfaces. (For example, vte-based terminals disable scrollback and automatically convert mouse wheel to arrow keys, if the program hasn't requested it explicitly.) The program enters the 'altscreen' when started, and goes back to 'normal' when exiting.

There is only one alternate screen buffer, and screen itself activates it. The altscreen option is needed to enable alternate buffer emulation for programs running inside.

share|improve this answer
    
I can't upvote you enough! –  George Dec 15 '12 at 9:11
add comment

Add this line to your ~/.screenrc:

altscreen on
share|improve this answer
add comment

here is a good link with common settings you should have in your screenrc or .screenrc http://wiki.linuxquestions.org/wiki/Screen

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.