Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

OpenERP defaults to using the MM/DD/YYYY in the GTK client, but I want to use YYYY-MM-DD. How can I change it?

share|improve this question
add comment

1 Answer

up vote 5 down vote accepted

As described in this forum thread, the setting is in the user preferences, but it's still a bit buggy (as of OpenERP 5.0.14).

First, an administrator needs to add a new language choice.

  • From the Administration menu, choose Translations: Application Terms: Languages.
  • Click the New button
  • Switch to the form view to see all the extra fields, including date format.
  • Fill in the date format you want, give the language a unique name and code, and check the Translatable check box.
  • Click the save button.

Next, the users have to choose the new language. Either they can do it themselves through the User: Preferences menu item, or an administrator can do it for them through the Administration: Users: Users menu item.

Things that don't work in OpenERP 5.0.14:

  • Changing the date format on the default English language entry. It seems to get ignored, except maybe in reports.
  • Double clicking on a language entry doesn't bring up the form view, and neither does clicking the New button. You have to explicitly click the Form button.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.