Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Chrome's Omnibox keeps sites that I most frequently visit - and this is good. However, one of my most visited pages has its URL changed, and I want to remove this from the Chrome Omnibox suggestions, how can I do so ?

share|improve this question

4 Answers 4

up vote 70 down vote accepted

You can do it like this:

  • Use your arrow keys to navigate to the entry.

  • Hold Shift and hit the Del key, release Shift.

  • On a full Mac keyboard with numpad, you have to hit ShiftDelete ⌦. On a small Mac keyboard, use fnShiftDelete ⌫.

The entry will disappear, but it might show up if you type another set of characters... Repeat it there.

A video demonstration shows how I clean the suggestions for the u character.

share|improve this answer
4  
Regrettably, this only works for URLs, not for Chrome's autosuggestions, which often clutter the limited number of items in the dropdown (6). –  Dan Dascalescu Nov 30 '11 at 10:04
    
Works partly in 17.0.963.46. I've managed to remove sample.com/index.php, but not just sample.com (and yes, I've removed it from the search engines). –  Olegs Jeremejevs Feb 11 '12 at 13:02
    
@MyFaJoArCo: Well, it's normal that it would appear as the address bar can also be used to search for things using your configured search engine. –  Tom Wijsman Feb 11 '12 at 13:59
    
@TomWijsman That's not my case, I've set up a custom search engine, without suggestions ("google.com/search?q=%s"), so it shouldn't normally display sample.com. Secondly, it looks just the same as a simple visited link (the same icon and text color as sample.com/index.php). Thirdly, if that was a suggestion - it isn't random, it's like I write "s" and always get superuser.com instead of stackexchange.com, for example. –  Olegs Jeremejevs Feb 11 '12 at 17:45
1  
@TomWijsman History is clear (by searching example.com), I don't have any bookmarks/favorites, it isn't in the FVS list (it's the one on a new tab, right?). I think it's a history glitch, something I can't see left in it. However, I don't want to clear the whole history to solve this, sometimes I forget some addresses. It's not that I'm very concerned about this, just wanted to be sure, that I didn't forget to check something obvious. –  Olegs Jeremejevs Feb 11 '12 at 18:40

Unfortunately, the suggestion by Tom Wijsman does not work for me - the site continues to appear with a clock icon. I found a related question with an answer which fixed it for me, by obliterating the History Provider Cache file, which is located:

Mac OS X

~/Library/Application Support/Google/Chrome/Default/

Windows Vista:

%localappdata%\Google\Chrome\User Data\Default

If you want to keep your other history, you can search the History Provider Cache for the offending sites and remove them.

share|improve this answer
    
However, this does not delete a single entry. Funny, you can do your suggestion by just wiping the history from the settings. Note the keeps sites that I most frequently visit - and this is good. in the question, which I think is also stored in that file. Indeed there is a weird thing going on, that only the globe icons work while the clock icons do not. Try waiting a small bit before hitting Shift + Delete... –  Tom Wijsman Mar 17 '12 at 6:42
    
If I remember correctly removing the History Provider Cache does not obliterate all of your history, which is stored in a separate file "History". The History Provider Cache is just that - a cache. However, you can still search the History Provider Cache and remove only the offending sites. –  lid Mar 23 '12 at 9:46

I would agree with Lid that Tom Wijsman's solution was not what fixed it for me. Lid's solution was closer, and one that I have tried several times but still could not get to work. I understand OP was looking to remove specific suggestions, but if you were in the same situation as I was (where I was unable to remove anything like that), the following should help you out.

I tried the keyboard shortcut deletes Tom Wijsman describes, clearing my entire history (since "Beginning of Time"), disabling syncing (in case the entries were stored in the cloud), disabling Omnibox History and Autofill specifically from syncing, clearing my synced data, uninstalling and reinstalling Chrome, and removing the History Provider Cache. None of these were removing the suggestions Chrome would give me based off my past brow

Instead of removing the History Provider Cache file, I actually had to remove the History file.

It's in the same path (Mac OS X /Library/Application Support/Google/Chrome/Default/ and on Windows I would assume C:\Users{username}\AppData\Local\Google\Chrome\User Data\Default as stated before).

I'm not sure why this was not being cleared out with the regular Chrome history clear. I noticed the file was 9.3MB.

share|improve this answer
    
This did it for me also - thanks. –  Rob Cooper Apr 20 at 13:51

I know of another way of getting rid of unwanted suggestions in the Omnibox, but it does require shutting off suggestions from logged history.

To do it, you type in chrome://flags and scroll down to Disable 'shortcuts' in the Omnibox and enable this.

There are also other options, such as the Use new scoring in HistoryQuickProvider, and Inline HistoryQuickProvider; however, I have not used these. I assume they would work, though.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.